I have 403 error when login by facebook app

I use plugin for wordpress to login by discourse.
But when I try to login to discourse by facebook app, it takes this error:

I think this cause by discourse login auth by google
Could you check this login issue on facebook app?

My login at this link:

Is anybody here?
This error is very important for my facebook customer now.

Hey there :slight_smile:

Sometimes you’ll find a slight delay in response when posting a support question late on Friday.

Your issue is not a WP Discourse, or a Discourse, one. It’s an issue caused by the fact that Google doesn’t allow OAuth2 logins in embedded browsers (e.g. Facebook’s embedded browser). You’ll find that a number of other websites have the same issue. For technical detail on the issue see here.

The solution is to use a normal web browser, instead of facebook’s web browser to use your Discourse instance, or perhaps allow for other login methods if you want to let your users use facebook’s web browser.

1 Like

Thank you,

Well, it seems not able to help fb user.
Some local facebook users are most. But because I serve for B2B, gmail from G login is very important to contact…

Is there any chance for google fix this issue in the future?


I have this idea,

Could you create an option to redirect to other URL when we have this 403?
This help we have more flexible to help user by some instruction

From Google’s perspective, it’s a Facebook issue :wink:

This is not a Wordpress-specific question, so someone from the Discourse team might be more qualified to respond on this, but given that this is an issue between two different services unconnected with Discourse (Facebook and Google), I suspect there is not alot Discourse can do. Keep in mind this issue affects many services using Google login when sharing content on Facebook. This is not specific to Discourse.

I’m curious, if this is a B2B case that requires you only use google login, where does the need arise to support a large number of users clicking through from Facebook? In most B2B contexts, users are not interacting with a forum through a Facebook share.

Moreover, the issue seems to arise from the fact that people are being auto-redirected to google login on clicking a link to your site. Another solution here is to let guests view the site without logging in, i.e. disable the auth immediately and / or the login required site settings.

If you’re sharing content on facebook, requiring login to view content is a somewhat odd move, on top of the B2B context?

1 Like

There are some conficts in using app in B2B here,

Facebook is not secure and there is not enough authentication for B2B. But because of custom in local or market demand, most of facebook users will force companies to keep using fb.

These aspects in market and technology make me have this issue.

A link without login is very appropriate. But there are 2 links in recommendation make users be confused than only one for login. So I wonder how to redirect to other link in 403 to keep first recommend link be only.

I suggest you just use one link, the link that doesn’t require the user to login. I wish I could help you further, but this is no longer a Discourse support question, it’s a question of how you’re designing your business workflows.

1 Like


When I use discourse wordpress plugin to login, it redirect to discourse and display forum first. This make customers misunderstood, and they try to click to forum, instead of wait for login window.

Could you make forum not to display before login window?