I have a very difficult problem installing ssl - please help

unsupported-install

(Salah SE Louergli) #1

I purchased the server, installed the script normally on the Digital Ocean site

Then I opened it normally, equipped everything and connected the domain also normally

You then start by converting the site to an https protocol, and you have the necessary settings, as in the following section: https://youtu.be/vAPuHBlcOms

And then the site stops working domain and ip words do not work?

What is the solution? Or should I get off?

Hosted Domain: http://elbwasil.com

For information: I made the mistake twice


(Stephen) #2

Why did you do this? The installation guide will set the site up with HTTPS by default. Which install process did you follow?


(Salah SE Louergli) #3

What do I do if, to link the ssl certificate correctly?


(Stephen) #4

If you follow the installation guide correctly the SSL termination is handled for you. No need to take any additional steps.

If you follow third party guides we can’t really support your installation.


(Salah SE Louergli) #5

No, I used the automatic installation on the Digital Ocean site


(Stephen) #6

We don’t support their one-click installation here. We can only assist if you’ve followed our installation guide, which takes care of this for you.

If you do follow our guide you won’t need to do anything twice, the documentation is excellent and little can go wrong providing you follow it in its entirety.

You may be able to get some help from DigitalOcean direct, alternatively try their community.

They do have a section on enabling HTTPS in their one-click installation, YMMV.


(Salah SE Louergli) #7

Enabling HTTPS

We strongly recommend using SSL to secure the connection between the Discourse server and the clients connecting to it. Discourse provides the following resources on setting up SSL:


(Jay Pfaffman) #8

try this:

cd /var/discourse
./discourse-setup

When it asks for the Let’s Encrypt email address, give it one.