Iconified Header Links

theme-component

(David Kingham) #21

My theme settings do not display either, I did install correctly using the importer. I’m on 1.9.7


(Joe) #22

@davidkingham

Theme settings were introduced recently on the beta branch and require Discourse V2.0.0.beta4 or higher to work.

You’re on the stable branch which does not have support for theme settings yet.


(Joaquin) #23

Hi there wonderful community! I’ve installed the theme extension and configured my social networks OK.


They look awesome! Now I would like to customize them since they are appearing in a very dim grey.
Maybe just color them greyish white and then white for hover.
Any idea on how I could achieve this? Thanks a lot!!!


(Vincent) #24

Yo @Johani – congratulations on making the Discourse team!

I think there’s a problem on small-width mobile screens:

Looks like the category selector is hidden behind the header (note how Safari is still better at hiding bugs :smiley:)

Cheers!


(Joe) #25

Hi @_vincent. Thank you :tada:

I’m not sure what to recommend here. Here’s what I’m seeing without any icons added:

As you can see, the combination of a text logo alongside the French local leaves you with pretty much zero space left for any extra icons. When you add any additional icon, the elements will wrap to the next line and therefore cover the category selector.

The theme has a built-in way to choose what devices to show the links on, so that’s one option. The other option is to set an image based logo. You can specify a mobile-only logo with the mobile_logo_url setting on your site.

You can also reduce the size of the font for the text logo if you decide to stick with it but even that won’t create that much free space.

Let me know if you have any ideas.


(Vincent) #26

I think the problem lies upstream. Header should be allowed to expand in height without overlapping content, shouldn’t he?

In the meantime:


(Joe) #27

If you’re ok with the header height extending and are only concerned about the overlap, one option you can try is this:

#main-outlet {
    padding-top: 100px;
}

More on that here:


(Joe) #28

Hi @bongotai

The icons generated by this component will follow the style of the rest of the icons in the header. The default way to control the color of those icons is to change the header_primary color in your color scheme:

if you’d like to go beyond that, you’d need to use CSS to get the results you need. You can use something like this:

.d-header-icons .icon {
    color: #999999; // icon color

  &:hover {
    color: white; // icon color when hovered
  }
}

(@SenpaiMass) #29

how do we use Fontawesome 5.1.0 with this ?


(Joe) #30

Updating to FontAwesome (FA) v5 is planned for future #releases. Until then, this theme will only work with the current version of FA included in Discourse (4.7) unless you modify it.

I recommend waiting, but if you must, then change line #15 in the </head> section from this:

helper.h("i.fa.fa-" + seg[1] + ".d-icon.d-icon-" + seg[1])

to this:

helper.h("i.d-icon" + seg[1])

You would then be able to add CSS selectors in the theme settings that support FA 5.1

So FA 4.7 twitter link would look like this:

Twitter, twitter, https://twitter.com, vdo, blank

The same link modified for FA v5 would need to be:

Twitter, .fab.fa-twitter, https://twitter.com, vdo, blank

All your links will obviously need to be updated as well. You cannot use both v4.7 and v5.1 at the same time in this theme.


#31

Something even more challenging … is there any way to include a D3.js based ‘gauge’ in the header? Obviously it would rely on linking the D3 library … is that legal?


(Andy Kopp) #32

Thanks just added the icons to my forum. I also did the mistake of having spaces at first. Now it works.


(Tyler S.) #33

Hey guys and gals, new to discourse, but have managed to have it up and running almost a month now with zero problems thanks to these forums! But I am having an issue with one signle icon “discord”. I am able to load up FB, Twitch and a custom no problem, but for whatever reason the Discord icon just refuses to load. There is an empty place where the icon should be and an active link but no icon.

I have tried the following combinations of the icon link:

Discord,discord,URL,vdm,blank
Discord,fab.fa-discord,URL,vdm,blank
Discord,.fab.fa-discord,URL,vdm,blank
Discord,fab.discord,URL,vdm,blank

Any suggestions?

UPDATE

Does anyone know what CDN version this theme addon is using for font awesome? Other people experiencing the same issues where still using version 4. I am wondering how to determine what version this is currently using and if it is possible to upgrade it to version 5 if it’s not already on it.


(Tyler S.) #34

Does anyone have a solution to this issue?


(Jeff Atwood) #35

Yes, the answer is already what you stated: we’re using Font Awesome 4. We are executing a broad switch to SVG based glyph rendering (instead of font icons) but this will take months, it’s quite difficult.