In the title, "''' are still converted in " ›"


I followed the answer here but still get the problem:

I updated Discourse using /admin/upgrade#/and with a git pull then a rebuild. Did I miss something?



That’s because we didn’t backport the fix to the beta branch. I just did. Please upgrade one more time.

After upgrading, either manually edit the title of affected topics or run the following rake task to fix the titles:

rake topics:update_fancy_titles

OK, the update worked. When I create or edit a post, everything is OK.


The rake task added the bug on ALL the post title of my forum (even the very old) :frowning:

1 Like

Did you run the rake task after upgrading Discourse? I’m not sure how the rake task could use the defective logic if it has been removed by the upgrade. :thinking: Maybe try again?


I’m note sure of waiting the end of the update… :grimacing:
I retried, nothing change.
Can I do a rebake?

It shouldn’t hurt. Not sure if it helps much in this case though and I have no idea why the rake task doesn’t work for you. It works in my dev environment.

hum, that’s weird. If I edit the title manually (add a space at the end + save), it works.
The rebake is running, I’ll keep you up to date.


Rebake changed nothing :frowning:
Do I have to come back to a previous backup and try again. Somebody has another idea?

Before you do that, please try rebuilding the container one more time and rerun the rake task. I just tried it on a test site of mine and the rake task worked fine there as well.


If I do what the task do manually, it works also :

[9] pry(main)> t.fancy_title
=> "Entrepreneur : comment gérer les moments d ›incertitude?"
[10] pry(main)> t.fancy_title = nil
=> nil
[11] pry(main)> t.fancy_title
=> "Entrepreneur : comment gérer les moments d’incertitude?"

I try rebuilding and tell you if it works


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.