Inaccessible links to private groups on profile pages


(TechnoBear) #1

Continuing the discussion from Make private group pages visible to only group members:

Steps to reproduce:

Create a group and uncheck “Group is visible to all users”

Add non-admin members to the group.

Each member will see the group as a link on their own profile (but not on others), but using the link will give an “access denied” error.

Either the link should not be visible to the member, or the member should have access to the group page.


(Zach) #2

Hi, I followed the steps you mentioned but the non-admin members do not see the group.
Could you attach a screenshot?


(cpradio) #3

This might be fixed now. Those in the Group can see the group page now, but those not in the group do not see it and can’t access it.

Group is a Link

Group Settings:

Clicking on Link as testuser3 (who isn’t staff)

Test User 6 viewing TestUser3’s profile page:

TestUser6 trying to access the Special Group Page via a direct link


(Jeff Atwood) #4