Incorrect S3 warning in admin menu

There is a possible bug in the warning being displayed on the admin menu of Discourse 2.7.0.beta1 ( 53f4d54f23 )

The warning reads:

In my settings, the following are set:

  • s3_access_key_id
  • s3_secret_access_key
  • s3_upload_bucket

This one is not set, and is probably triggering the warning:

  • s3_use_iam_profile

The details of this setting say:

Use an AWS EC2 instance profile to grant access to the S3 bucket. NOTE: enabling this requires Discourse to be running in an appropriately-configured EC2 instance, and overrides the “s3 access key id” and “s3 secret access key” settings.

However, my Discourse is not running in an appropriately-configured EC2 instance so I therefore don’t want it to override the “s3 access key id” and “s3 secret access key” settings. My Discourse is running on Digital Ocean.

So this option, for me, is correctly not enabled.

Which I think means the warning displayed on the admin panel should not be displayed in this scenario? :thinking:

My S3 uploads are still working fine and have been for years with no changes made anywhere :+1:t2:

3 Likes

There is a new warning for people using S3 without a CDN that I merged yesterday. Looks like I got the error message wrong :facepalm:.

Will be fixed by

@Richie are you deliberately using S3 without a CDN? I added this warning because we got multiple topics in Meta about site admins paying way too much money for S3 because of the egress traffic costs.

7 Likes

My s3 cdn url setting is currently blank so yes, I probably am.

Thanks for the bug fix :+1:t2:

2 Likes

Although…

Does this mean the CDN warning will be visible all the time in the Discourse admin panel now instead?

Even if I choose never to set up a CDN? :thinking:

2 Likes

Yes, the idea is that using S3 without a CDN is a obvious mistake and everyone that is paying for S3 in a production instance can afford to pay for S3 and a CDN for less money.

One possible workaround if you are somehow stuck in S3 without a CDN is setting s3 cdn url to the bucket URL, so it becomes a noop.

4 Likes

Interesting.

Ok, thanks @Falco I’ll install the above fix over the next day or two and open a new #support post if it get stuck :+1:t2:

3 Likes