Issue in setup discourse on ubuntu server

I am trying to install discourse on an ubuntu server. Every command is successful until this command which gets stuck : bundle exec rake autospec. If I run bundle exec rails server by skipping previous command, it runs but I am not able to access the portal on port 3000.

I am folowing steps mentioned here :


RAILS_ENV=development bundle exec rails server --binding=

This is the issue i guess, But I am not sure how to resolve this. Anyone??

How much ram do you have? What does

 free -h


What are the minimum system requirements for discourse setup?

1GB of RAM with SWAP, I think you need at least 2GB of SWAP.

That’s true for a docker install, but a development install will likely need more than that.

Do you need a development setup?

You might try Beginners Guide to Install Discourse for Development using Docker, but if you want to do development you’ll likely want at least 4gb.

I’ve run development environments off the DO $5 droplet and they work just fine. Not fast but not unbearable either. CPU speed is probably more important.

@Vishal_Kaushik do you have anything else running on this server? And is it a cloud server or something local?


I asked my devops guy to create a new instance with better specs and it worked fine on it. Thank you all for the help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.