Issue installing Discourse on OVH VPS Ubuntu 22.04

I try to install Discourse on OVH VPS Ubuntu 22.04 by following this doc: discourse/ at main · discourse/discourse · GitHub

The 443 port seems to be open because when I run sudo ufw status I get:
Status: active
To Action From

22/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
22/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)

But When I run: ./discourse-setup

I’ve got the following message: Port 443 of computer does not appear to be accessible using hostname mydomain

When I modify manually the /containers/app.yml I succeed to install correctly discourse only with http but I doesn’t work when I try to open it with https
I get the following message with https:
This site is inaccessible
mydomaine does not allow connection.

Does anyone know how to do proceed please ?


I tried also this method : Installer discourse pas à pas - YouTube
Same result : it’s work with http but not with https

If you’re using cloudflare make sure to use dns only mode.

Thanks Jay for your feedback. I use OVH and not cloudflare.

Are you using a reverse proxy of some sort?

Discourse-setup does a rather crude test to see that it’s possible to connect to itself with curl and your hostname. It seems like something is keeping lets encrypt from connecting to the server. If you rebuild enough times time hit rate limits that will keep you from getting a certificate for a week

@pfaffman no reverse proxy. I have installed nothing I just followed tu user install.
sudo systemctl status nginx
Unit nginx.service could not be found.

What connection do you need? Is it HTTP or HTTPS? I didn’t understand what you meant

Hello @xiaokong23357 I need https but so far it’s works only with http.

What are you using for DNS for your domain?

My only other guess is that your VM has port 443 blocked at the network level (before it gets to your VM). You can check with your VM provider to see if it’s blocked somehow. If it’s AWS then you need to muck with security levels, I think.

@Timelord, I use the DNS provided by OVH
Vous utilisez actuellement les serveurs DNS OVH recommandés pour votre domaine :

Hi @Titi :wave: :fr:

Can you provide us the exact configuration of your server, with the option you opted-in?
I rent a a VPS at OVH and I know they propose a bunch of stuff to be checked in or out.

@Canapin, you will find my configuration below:
Model: VPS vps2020-value-1-2-40
Vps with linux distribution
OS / Distribution: Ubuntu 22.04
Zone: Region OpenStack: os-sbg8*
Memory 2GO SSD NVMe
Storage 40GO
I don’t took the option cPanel & Plesk

1 Like

Thank you!

Did you try this step? OVH is often a bit slow to reply, but that may be helpful.

Yes @Canapin for sure. This is their feedback:
Thank you for contacting OVHcloud support.

I have just checked the proper functioning of your service and I confirm that at our level no incident has been observed on our infrastructures.

Help with software configuration is not part of the scope of support, I invite you to contact our community in order to find the necessary help.

I might leave this topic to more experienced users (I’m just a random passerby :smile:), but by chance do you have any other web software running on your VPS? :person_shrugging:

1 Like

I have lauched no other software on my VPS. I get a VPS especialy to set up my Discource. But I don’t know if OVH launch something on the VPS. How can I know ?

Could it be your misconfiguration?
Discourse programs can use HTTPS
Check the templates item “templates/web.ssl.template.yml” in app.yml for the introduction of template files; Next, you have to check the expose entry - “443:443” # https
Whether the template is enabled

1 Like

The default SSL certificate directory for discourse is under /var/discourse/shared/standalone/ssl/

@xiaokong23357 yes I check your points :