Issues configuring AI image captions

Setting seems to be set:

But there doesn’t appear the ‘caption’ button in the editor:

How can I make it work?

1 Like

If you want to use this on your own instance you need to set your Configure API Keys for OpenAI and then set the aí image caption model to use it.


I generated the open-ai secret key here:

And pasted that key here:

Also ai plugin is working ok:

But I was expecting the image captioning to work here (it didn’t):

1 Like

You have to create API at OpenAI, it is theirs. And pay too

My bad, I didn’t have my reading glass.

Are you using right model? And groups are ok? Do you see any strange errors?

1 Like

I don’t know. What’s the ‘Modal’?

Yes I hope so. I didn’t touch most of the default settings since I setup my website a few years back.

No, not at all.
I can post a video if that’d help in helping me.

1 Like

Model of AI is basically like if using Mac or Windows, or in this case is using Win10 or Win11. Out there is different type AI solutions and those have different models.

But you are interested in these settings:

Same thing what Falco said earlier:


And website is same as your forum? But few years back there wasn’t AI available and by default all AI-settings are kind of off. But you have create API by OpenAI so you have changed at least some settings. Should you doublecheck who can use AI helper then?


Per this post:

You are trying to use wrong model. You have llama in use, but you are customer of OpenAi.

You were correct, ‘Ai Helper Features’ didn’t have ‘Image_Caption’ selected.

Also, ai helper image caption model was corrected.
But now when I click ‘Caption with AI’ in composing window, it is giving ‘500 error’.

My current settings:

1 Like

Calling @pfaffman @itsbhanusharma
Can you pls help, if it (“Error 500” while generating auto-captioning photos in Composer window) is some small omission/commission from my side.

1 Like

Sorry, not an AI expert by any means. But 5xx series errors are server side so it could be that the AI endpoint is not working as expected? Can you check the logs to see if there is something obvious there?


Whatever research I was able to do, I find that perhaps I need to be on a higher ‘Plus’ plan of Open-Ai to be able to use ‘Open Gpt-4 Preview’. Because I find the ‘Ai-Image-Captioning’ only allows 2 models, either Llava (which I couldn’t know how to create api etc), and Gpt-4.

So that may be the problem that Open-Ai Api key isn’t allowing the usage of ‘Image Captioning’ to me.

If I’m correct, I’d recommend to mention this fact, under that ‘Image Captioning’ site in Discourse Settings.


Plus plan is for ChatGPT and that you use only via website of OpenAI. It has nothing to do with this. In your forum you are using API and API is charged totally differently usin pay-per-use and that price depends what model you are using and how many tokens you are spending.

I’m totally sure your settings are still wrong somewhere.


I’ve set this Open_Ai secret key:

Still, as the below given SS shows, ‘Open-Ai’ doesn’t give any response to me (and I think this is the culprit of not responding to my calls to Ai-generated-captions):

I say this, because Ai_Generated-Captions need either Llava or Gpt-4-Vision-Preview to work:

1 Like

I would not offer help, but you asked.

Check the logs for the error. I’m pretty sure when I’ve seen a 500 error it was because my account was out of money, so it’s almost certainly (in my very limited experience) something about the other end refusing to do the work.


I don’t argue against, because it was some time ago when that happened to me, but I’m quite-almost sure it didn’t show up as error 500 when trying to run some operation (like that newer semantic popup search that gives error 500 on my forum).

It shows up in error log as 400, 429 or something like that, but not error 500 — its role is totally different)

API of OpenAI has/had some issues, but it happened just recently and OP’s headache has been there longer.

But I had money issue in my mind too, but only because of that mix with ChatGPT Plus.


Ok. Its not my place to ask ‘why’. Also because you’ve already helped a lot many-many people around here, including me. Even perhaps the people who, including me, didn’t deserve that much help.
Reader will perhaps take it as ‘pampering’, but truth is, but for @pfaffman , many people, including me, won’t be using ‘Discourse’ based websites today. As, 4-5 years ago, ‘Discourse’ seemed/was too difficult to install and setup for wordpress people in the initial years. And it was then that @pfaffman kept answering similar questions again and again, patiently, of all new users. Sometimes even users like me were afraid, whether it was ethically correct to ask so much naive questions to one helping body!!

Only people like my skillset, who setup discourse websites around (or before) 2018 can truly appreciate @pfaffman 's contribution to Discourse community. And I don’t know what’s it like today, but at that time, ‘D’ team was very limited, and helping hands were severely few (read ‘one’ only). I can only wish, if someday ‘D’ success story counted the persons behind its success, P was kept in the row of first few people without whom, it wouldn’t go that far, in that much time (excuse me for my English).

At least money doesn’t seem to be the issue (check out SS below):


1 Like

When I look at that image I see “State: Expired.”

I’m pretty sure that “Expired” is not a state in which you can get it to do work.

You can also look at the logs and see the error there.

Because I don’t have much expertise in the AI plugin, so I’d let someone else answer.


I checked and have deduced that those are merely those (free or paid I don’t remember) credits which got expired last year (seeing the ss carefully confirms this).

When I tried to buy new credits, it only increased my limit from $5 to $120 now. But credits still show in ‘Expired’ state.

Still, its you only, who put up me in some (right) direction.

And last, you won’t believe, and I don’t know if I’m allowed to say so here or not but, I too am a small Pfaffman in my local community. Proofs of which are available on Google, but most in my own native ‘Hindi’ language. My website.

1 Like

That’s quite flattering. If I didn’t recognize your contributions I’d likely not have answered so willingly. I know you’ve helped many people here.

Well, that’s in support of my original claim that I don’t know anything about this! :rofl:


Just to record things correctly, I didn’t help people on this (meta) website. I’m recognized as a ‘helper’ in my local (Bathinda) city circle, community (thus my website name: Bathinda Helper).

@Falco can you pls see why Discourse isn’t sending any api request to (as this below given activity tab of ai website shows), even when I’ve tried to Caption diff images in my composer window?

My other relevant settings SS have been posted above, I think repeating those won’t be good.

1 Like

I’m quite sure that is one problem too. Have they withdrawn money from your card?

An account with credit should look like this one:

And the reason why there isn’t any tokens moving is

  • you don’t have any other AI-activities on
  • error 500 happends on your site (but the reason for that could be lack of credits, but then your error log must show something)

If your log is empty, or there isn’t any relevant happenings, I still claim your settings aren’t right.

For example.

We can use new AI-semantic search. On my forum it gives error 500. It is not happening because of issues on OpenAI side (or so I reckon) but because this error Failed to process hijacked response correctly : ArgumentError : address cannot be nil or empty and comes from my end.

Sure. It can be a bug or my settings are funny, but my point is when you see error 500 on your screen it raises from your setup. And because AI captioning works AFAIK everywhere else but not for you then the issue is

  • your settings, or
  • somehow your version