Issues editing posts on linode image

Same kind of problem, getting a 500 when trying to edit a post.

Started PUT "/t/tutoriel-fiches-modeles/21195" for xxxxx.142 at 2022-11-15 11:20:30 +0000
Processing by TopicsController#update as */*
  Parameters: {"title"=>"Tutoriel : \"Fiches modèles\"", "tags"=>[], "featuredLink"=>nil, "category_id"=>5, "slug"=>"tutoriel-fiches-modeles", "topic_id"=>"21195", "topic"=>{"title"=>"Tutoriel : \"Fiches modèles\"", "category_id"=>5}}
Completed 200 OK in 136ms (Views: 0.6ms | ActiveRecord: 0.0ms | Allocations: 3960)
Started PUT "/posts/64949" for 81.245.109.142 at 2022-11-15 11:20:30 +0000
Processing by PostsController#update as */*
  Parameters: {"post"=>{"edit_reason"=>"", "image_sizes"=>{"https://xxxxxx/uploads/default/original/1X/c6358a5df899b5d4a02afa831b1dde70ccf9826c.jpeg"=>{"width"=>"480", "height"=>"360"}}, "cooked"=>"\n        <p>Voici un petit t>
Completed 500 Internal Server Error in 470ms (ActiveRecord: 0.0ms | Allocations: 21862)
Redis::CommandError (ERR Error running script (call to f_59f11a23aa67ac7571a445b8f005b3ef4bb0c5f8): @user_script:11: ERR value is not an integer or out of range)
lib/discourse_redis.rb:190:in `eval'
lib/rate_limiter.rb:162:in `rate_limiter_allowed?'
lib/rate_limiter.rb:122:in `performed!'
lib/post_revisor.rb:579:in `perform_edit'
lib/post_revisor.rb:395:in `revise_and_create_new_version'
lib/post_revisor.rb:299:in `revise_post'
lib/post_revisor.rb:211:in `block in revise!'
lib/post_revisor.rb:210:in `revise!'
app/controllers/posts_controller.rb:264:in `update'
app/controllers/application_controller.rb:413:in `block in with_resolved_locale'
app/controllers/application_controller.rb:413:in `with_resolved_locale'
lib/middleware/omniauth_bypass_middleware.rb:71:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
lib/middleware/anonymous_cache.rb:368:in `call'
config/initializers/100-quiet_logger.rb:23:in `call'
config/initializers/100-silence_logger.rb:31:in `call'
lib/middleware/enforce_hostname.rb:23:in `call'
lib/middleware/request_tracker.rb:202:in `call'

Ar you using the official Discourse install?

1 Like

If remember well, I used the image available on the Linode marketplace as my server is hosted there and that was the quickest and simple option for me to set up the instance. The instance is regularly updated with the latest maj and connected to our SSO solution with the keycloak openid plugin. I’ve tried to rebuild everything but with no change.

This is not a new instance - the current forum is running since the end of 2020.

We have set parameters for edits:

post edit time limit : 1440 (1 Day)

tl2 post edit time limit : 7200 (5 Days)

Trusted level for the user having the bug was : 2 : member
The post he tried to edit was less than 24h old.
And I’ve successfully edited the post as an Admin.
Still can’t figure it out.

Thanks in advance.

Gaël

You are going to need to migrate to the official image. Old linode images are in the “unsupported” category sadly.

1 Like