Issues with an Azure install (need to configure inbound ports)


(Dave) #1

I’ve just installed Discourse onto an Azure Ubuntu server using the 30 minute install guide.

When it finished the web site hadn’t started. I than ran ./launcher start and got the error:

Config file was not found, ensure containers/.yml exists

Available configs ( app )

I ran ./launcher rebuild app and then ran than ran ./launcher start and got the same error:

Config file was not found, ensure containers/.yml exists

Available configs ( app )


(cpradio) #2

I think you want to run ./launcher start app (though running ./launcher rebuild app should have started the app)


(Dave) #3

/var/discourse# ./launcher start app
f50c3196399d
Nothing to do, your container has already started!

When I connect to the IP address or URL I get a ERR_CONNECTION_TIMED_OUT.

How do I troubleshoot this further from here?


(cpradio) #4

I would start rummaging through /var/discourse/shared/standalone/log to see if anything seems related and post that here


(Felix) #5

I get same error as you.

Is this fixed?


(Jay Pfaffman) #7

I do several installs each week; it is not clear what the problem here might be, but it’s almost certainly not one that is on the Discourse side of things. This problem is likely something like getting the IP number wrong or a firewall setting.


(Felix) #8

Hi Jay,

I’ve just installed Discourse onto an Azure Ubuntu server 16 using the 30 minute install guide.

What log file should I upload?

root@ProdServer:/var/discourse/shared/standalone/log/var-log# ls
apt  auth.log  dpkg.log  kern.log  nginx  syslog  unattended-upgrades

By the way, I also installed Discourse onto my local Ubuntu Desktop 16 using the 30 minute install guide. No issue found.

Is this because of Azure/Ubuntu Server network setting?

Thanks.
Felix


(Jay Pfaffman) #9

Sounds like Ubuntu works and azure doesn’t to me. Not a wall I want to bang my head on.


(Jeff Atwood) #10

Jay I can pay you to do a $99 install test on Azure / Ubuntu Server just to see if it works. No need to bother setting up email, just see if it installs and loads?

Because I am curious. It should work.


(Jay Pfaffman) #11

Trying to get me to bang my head? :slight_smile:


(Jeff Atwood) #12

It really should work. And only $99 of head banging, no email needed. :metal:


(Jay Pfaffman) #13

OK, here’s the report:

I created a DS1_V2 (~$55/month) virtual machine running Ubuntu 16.04 LTS. I did

wget -qO- https://get.docker.com/ | sh
apt -y upgrade
./discourse-setup

It worked just fine.

Oh. You see? I knew there would be head banging. Turns out, not being able to access your machine is a feature, not a bug. You need to open the ports, like this.

Once I managed to convince Azure to open port 80 so that one could access it via a web browser, I enabled Let’s Encrypt and rebuilt. That worked too. (And to make sure that there was no outbound filtering, I sent an activation message with Mailgun. No shenanigans were required.).

https://azure.ltcmp.net/


(Felix) #14

Thanks for Jay’s test on Azure.

I followed the setps below to open port 80 and it’s working now :tada:


(Blake Erickson) #15

@pfaffman and @LiveLikeLastDay good work getting it running on azure. :slight_smile:

I’ve installed discourse several times on azure and it works great. Just wanted to say that yes they can have expensive Linux VM hosting (A1 v2 2GB is $26.79+/month) compared to digital ocean, but if you apply for their BizSpark program you can get 2-3 years worth of $150/month in Azure credits :money_with_wings: so it might actually be the cheapest hosting solution.


(Jay Pfaffman) #16

OMG. I tried to log in today to turn off the instance that I started. There is no link (that I could find) on https://azure.microsoft.com/ to actually log in to an account (pro tip: it’s not the “my account” link). Then I found my way to https://manage.windowsazure.com/ which is also not how to find the instance I started up yesterday; maybe that’s just VMs that run Windows? Finally, I found https://portal.azure.com/ and was able to shut down the VM I cranked up yesterday.

My gut reaction is that they’d need to send me a check for $150/month for me to learn to use their services, but that’s probably unfair.


(Blake Erickson) #17

Make sure you deleted everything in the resource group that was created when you made the vm. If you just delete the vm it might have left behind things like VHD’s and storage accounts.


(Jay Pfaffman) #18

Thanks. That was relatively easy. Some of the complexity of Azure is a necessary side-effect of it’s flexibility. That doesn’t make it any easier for people figure out, though.