Language detect issue [missing %{language} value]

Hi team:

Thanks for the great plugin which helps me a lot.

Recently I found there’s an issue about the language detect, the new posts always couldn’t be detected the original language.

Message

RuntimeError (The translator is unable to translate this language.) /var/www/discourse/plugins/discourse-translator/services/discourse_translator/google.rb:70:in `translate’

Backtrace

/var/www/discourse/plugins/discourse-translator/services/discourse_translator/google.rb:70:in translate' /var/www/discourse/plugins/discourse-translator/plugin.rb:40:intranslate’

Env

hostname flutter101-app
process_id 180
application_version 9a3dd6b59af0a5fc22045f376b421cb4fd074aad

Is there anyone who faced the same situation?
Thanks!

Is this 100% reproducible?

Can you paste the problem text here?

4 Likes

thanks to Sam, for your quick reply, yes, 100% reproducible, the Chinese text is:

还真是,新发布的帖子调用 MS 翻译都是报错,老的就没问题,为何内。

I have recorded a screen for this, you may see from that the new text had this issue, but the former post is OK.

I am using the MS translate.

Please check it out here, thanks!

I have tried rebuild app, not working :pleading_face:

Today I’ve upgraded to the lastest version and stil not work, FYI, thanks :sweat_smile:

@Luke_Cheng Can you try upgrading to the latest? @pmusaraj might have fixed it in

as I’m unable to reproduce the issue.

5 Likes

Great, thanks to @tgxworld and @pmusaraj!