Links in popular links appear without nofollow


(Spooky) #1

Is it possible that the links in the “popular links” section will appear with nofollow as well, they do in the post itself. In the settings I’ve enabled the nofollow option, but for some reason the links in the popular links section don’t show it.


(Evgeny) #2

nofollow no :frowning:

And if just add here: nofollow (topic-map.js.es6)? It does not make sense to open in 2 places. Messages already have a link.

  buildAttributes(attrs) {
    return { href: attrs.url,
             target: "_blank",
             'data-user-id': attrs.user_id,
             'data-ignore-post-id': 'true',
             title: attrs.url };
  },

(Spooky) #3

having follow links there is a golden gate for spammers.


(Felix Freiberger) #4

While I’d like to see this added so spammers don’t even think they can place a good link there, this isn’t an actual problem – these links are not visible to search engines. Here’s how this page looks like to Google:


(Evgeny) #5

Yes, I agree. If the costs are minimal, then why not add? Spammers can not look at the document that they see to search engines (and not all, but only those that are written in the file: crawler_detection.rb)

I already have cases where spammers target this part of the code and register to add a link.


(Felix Freiberger) #6

This should cover all search engines that are either detected or do not execute JavaScript, I think that this misses almost nothing :slight_smile:


(Evgeny) #7

In file: crawler_detection.rb

  def self.crawler?(user_agent)
    !/Googlebot|Mediapartners|AdsBot|curl|HTTrack|Twitterbot|facebookexternalhit|bingbot|Baiduspider|ia_archiver|Wayback Save Page|360Spider|Swiftbot|YandexBot/.match(user_agent).nil?
  end

Mozilla Firefox 34.0 -> about:config -> general.useragent.override

I add those bots that are not on the list. In fact, a lot of search engines:StackRambler, Teoma and etc.
As a result, I see a normal page

Am I doing something wrong?


(Felix Freiberger) #8

To get the screenshot above, I simply disabled JavaScript. :slight_smile:


(Evgeny) #9

I understand everything, thank you. )


(Sam Saffron) #10

To me this looks like a bug a pretty bad bug.


(Sams Sock) #11

I am sam’s sock, posting a link to www.cnn.com


(Evgeny) #12

I do not know the engine well, but I looked at the complaints from the search engines. Many search engines want, for example, to see a header (h1) on each page. In my copy, I had to manually insert this header into the source (on some pages: latest, for example). If there is a problem with the links (not in Google, Yandex, and in other lesser known systems), then I think it’s probably worth considering more carefully.


(Sam Saffron) #13

Note, this will only impact crawlers that use JavaScript. Nonetheless the trivial fix is just to disable follow in that section. It adds a minimal amount really.


(Jeff Atwood) #14

Can you add this to your list @techAPJ? I think it is pretty easy, just always have nofollow in this section. I don’t think it applies to crawlers since it doesn’t appear there.


(Arpit Jalan) #15

Done via:


(Jeff Atwood) #16