Links to my forum do not work when posted to social media


whenever I repost a link to my Discourse forum let’s say to Facebook, it leads to a non-working page. And if I post a link to any discussion anywhere on social media, then the discussion which opens consists of a blank white page, no replies and just the title. On the forum, the discussion displays without issues.

Basically, any sharing of a link to my forum on social media leads to an error page. When posted on social media, the hyperlink gets various letters and numbers added to the end and I guess this is what is deeming the address unworkable.

Does anyone know what is wrong and any way to solve it?

Could you send a link here by chance?


I would prefer not to share domain in public but this is what happens when someone clicks on a reposted thread on FB:

And when I post a direct link to the forum itself (not specific thread), then it’s just a blank non-working broken error page.

After clicking on the domain on FB, then in the browser, the address is followed with something like ?fbclid=IwAR3o9S5-qlt2_CMmFVoHpEsntmYymJfAGz-6gDvW6H9XE8y

But the domain won’t open.

The only way how my domain opens is after typing it manually into the browser.

So the link looks for example like this?

Does the same happen with links to other forums like this one or does it only happen with yours?


Yes, just like that in the browser.

When I post on FB, the link is normal. Once you click on it, in the browser there are letters and numbers added to the end.

I just tried to post a link to this (meta discourse) thread on FB and it added the numbers and letters as well into the browser. But the redirect perfectly worked.

So, it must be a problem that the forum is somehow not accepting redirects when the letters and numbers are added.

Could you copy the URL Facebook changes it to and just redact your domain (possibly topic name as well)? And perhaps the same for Meta as well as a proof-of-concept?


I don’t think the issue is with the link being transformed when posted on FB, since this happens whenever you post any link to social media - these letters and numbers are also added to the redirected link.

But somehow my domain doesn’t work unless it doesn’t contain any additions.

Again, could you provide a redacted example from your site alongside one from Meta?


The topic your trying to post on Facebook or other social sites. Is the Topic viewable if not logged into your site?

If Security setting does not have:

  • Everyone. See

Then external sites will get an error.

Since your reluctance to share a link. I suspect your trying to share on Social sites restricted topics that you need to be logged onto your site

1 Like

There are no restricted topics, it’s just a normal forum.

I tried hiring 3 different people on Fiver and no one could advise me what is wrong.

I just noticed, that actually any direct hyperlink to a thread on the forum will lead to a broken page showing just the thread title but a blank white instead of its content.

If I just put a link to any thread on the forum into a browser - a blank page opens. When I click on the same page directly on the forum, it opens without issues.

The issue started happening since we restored the forum from a backup.

When I have it installed for the first time, everything worked normal till restoration from backup.

Is there anyone familiar with Discourse who provides paid services of fixing Discourse related issues?

I believe a marketplace topic would work well for that.


Anyone could possibly help in a topic. But you would need to post perhaps some screenshots.

As you have mentioned it was fine until restoring your site. As @Firepup650 mentioned Marketplace might be best if your Willing if needed to permit them access.

1 Like

I believe this has been resolved?


This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.