Lock down sassc version

Currently if you would bundle update you would end up with sassc (2.0.0) which breaks on precompiling assets with Error: error C function image-url: initialised constant SassC::Script::String

Locking down the sassc gem solves this issue.

gem 'sassc', '~> 1.0', require: false

I will try and figure out what breaks and get a solution for sassc ‘~> 2.0’…

4 Likes

I am definitely for the more ideal version of just figuring out how to upgrade sassc. PR totally welcome on that. It is going to be related to our sass customizations for themes and so on.

3 Likes

Just ran across this myself in development mode with git pull and bundle install.

Thanks for the workaround.

bundle install will certainly not cause it, bundle update will. I would like to get sassc upgraded though in Discourse that would be nice.

Sassc is now updated

5 Likes

This topic was automatically closed after 24 hours. New replies are no longer allowed.