Mail error 504 5.7.4 Unrecognized authentication type

Hi there,

just installed a new board @ aws and want to get the mailing running.
I tried to send mail with swaks from host -> ok
I tried to send mail from within the container (with swaks) -> ok

The command i used is

swaks -server <my_mail_server>:587 -tls --auth-user <my_mail_user> --auth-password <my_mail_pw> --to <my_testaddress> --from <my_mailbox_address>

The corresponding section in app.yml looks like this:

DISCOURSE_DEVELOPER_EMAILS: ‘<my_mailbox_address>’

DISCOURSE_SMTP_ADDRESS: <my_mail_server>

and these are the last lines of my app.yml

  - exec: echo "Beginning of custom commands"
  ## If you want to set the 'From' email address for your first registration, uncomment and change:
  ## After getting the first signup email, re-comment the line. It only needs to run once.
  - exec: rails r "SiteSetting.notification_email='<my_mailbox_address'"
  - exec: echo "End of custom commands"

So, In my oppinion I did everything …

But why is curious is that when I look in the logs I see this :

Delivered mail c73248c3-a56b-4100-a34b-63ad1eb3dab8@<some-domain> (5275.2ms)
Job exception: 504 5.7.4 Unrecognized authentication type

The thing is, that the <some_domain> is strangely the domain of the certificate I created for the instance

Don´t know how that is related :frowning:

Any hints what I could do ?

The last part with that domain is just a thought and I don´t know if it´s any problem. The

Job exception: 504 5.7.4 Unrecognized authentication type

could be a hint, but as I said … swaks does its job perfectly.

Thanks and cheers guys,

1 Like

Really no one ? … that´s bad :frowning:

I´m out of ideas …

Have you tried all the steps mentioned here?

1 Like

Hi @rishabh, I tried everything anybody suggested here, I guess :slight_smile:

Can I somehow reproduce the exact way how discourse tries to send mails … I mean, I´m not a ruby guy, but are there by chance tools with which to send mails from commandline, which are using the same mechanisms ?..

can´t seem to solve this :frowning:

solved it now :slight_smile:
This one helped me with it:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.