Manual Backup to my Computer Not Working

I have always been able to back up Discourse manually every evening and then download the file to my computer. An email is sent to me with a download link to click. That worked fine until about three days ago. The link doesn’t work anymore, and a tab is opening in Chrome when I click on the download link, saying,

“Sorry, this backup download link has already been used or has expired.”

But I have not used that backup previously, and this message never came up before. Am I doing something wrong?

Please advise.

Thanks so much,
Wes

1 Like

Are you logged in as the correct user?

Are you sure that your email client isn’t presenting an old link and you just need to scroll down?

Don’t mean to offend, but it’s likely something simple.

1 Like

No offense taken at all. Yes, I am logged in as the Administrator, as always, when I do this. And I only have one Administrator account.

Before I back up, I delete the old manual backup files, if there are any, so it’s empty. Here is my sequence in pictures and words:

  1. I go to the backup section and click Backup.
  2. "Do you want to start a new backup? I click YES.
  3. When it’s done, I get the green mark, and it says "Backup completed successfully.
  4. I go back to Backup in the Admin section and click DOWNLOAD.
  5. A link is sent to my email (see pic 3 attached).
  6. I click the link, but instead of downloading the file, a new tab opens in Chrome (see pic 4). I have tried other browsers, but it makes no difference.

1

Picture 2

Picture 3

Picture 4

Go into Admin > Settings and search for force_https

If you find it, enable it

1 Like

I did, and now I can’t log in. What to do?

the forum is still sending out http:// links and not https://

1 Like

go to mysite.com/u/admin-login and try and login from there

I noticed I was also logged in to another browser, so it is fine. I unchecked the force_https box again so I won’t have login problem.

However, before I logged out, I tried the backup with the force_https checked, but it made no difference, unfortunately…

private message me the link to the backup

Maybe it’s because I’m a new user, but I can’t find the Message button when I click on your profile.

I still can’t figure out why the file suddenly sends a http version instead of https, regardless of whether I check the https box. I’m not tech savvy at all, so I also contacted Gigenet, which hosts Discourse for me, to see if it was on their end, but they said it is a Discourse issue, and that they suggested someone looked at the Discourse log.

So, I think this is what Gavin wanted to do by signing up as an admin, but I haven’t heard anything back yet, and no one has tried to sign up. You may have been busy, of course. Just wanted to let you know that the problem persists… --Thank you.

Your SSL cert does not show lets Encrypt, which is used inside the docker.

Try ./launcher rebuild app via ssh (command line).

I’m sorry, Gavin, but this is way above my non-technical head. I don’t know how and where to run anything and what to do after that.

Send me the login details in personal message and I will look at it later.

1 Like

Thank you! I will…

After reading the discussion on SSL/No SSL conflict, this is what I did and it worked.

The link that I received in the email was an HTTP: I manually accessed it with HTTPS: and it worked.

email link > Copy Link address > Paste in the address bar (don’t press enter or the link will expire) > change “HTTP” to https in the start > Enter. the download should commence without an error now.

It sounds like force_https isn’t on. It’s usually turned on by default, but you can look for it in settings.