Backup link send to mail failed to download


(Praveen Kumar P S) #1

Hello Guys,

I have tried to download backup of my site couple of times, but the link send to mail failed to download every time. The link just showed a blank white page. The error logs shows following errors:

ActionView::MissingTemplate (Missing template admin/backups/show, admin/admin/show, application/show with {:locale=>[:en], :formats=>[:gzip], :variants=>[], :handlers=>[:raw, :erb, :html, :builder, :ruby]}. Searched in:
  * "/var/www/discourse/app/views"
  * "/var/www/discourse/plugins/docker_manager/app/views"
)
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/actionview-5.1.4/lib/action_view/path_set.rb:46:in `find'

(Wade) #2

Although I haven’t checked my error logs, I appear to be having the same issue. I just tried to download a backup from the link provided in the email and got a white page and no downloaded file.

As a workaround I downloaded them manually via SFTP after finding the backup files located in /var/discourse/shared/standalone/backups/default.


(Jeff Atwood) #3

Can you repro this @techapj?


(Praveen Kumar P S) #4

@codinghorror
For fresh manual back up, the download link works fine. You have to download it immediately and if failed to download with in a couple of hours, then it wont work. Not sure weather its a security measure or a Bug!!


(Arpit Jalan) #6

Yeah, as soon as the download is started the token expires (as a security measure). The error (white-page) you are seeing is a bug, instead a proper error message should be displayed. Fixed via:


(Jeff Atwood) #7