Menu, title collumn, and a lot a stuff are gone


#1

Hi there!

Just testing fresh instance of discourse and try some settings then this morning a lot a stuff are gone.
A jpg is more simple to explain the situation.

I will install discourse again but I would like to avoid reproducing this error. And currently I do not see what setting could have led me to this situation.

It’s a screenshot from the entire screen.

Same things on safari, opéra, firefox and ios app.


(Markus) #2

Did you tried to turn off all plugins (app.yml) and theme / css hacks? I guess there is something over customized :wink:


#3

Do I have to comment git clone line with # and rebuid app?


(Markus) #4

Yes. Except the docker manager.

# - git clone ...


#5

Just done. no effect after have emptied the cache from my browser and I did not change the css


(Evgeny) #7

On your site a version is displayed, which is provided to search engines. Very strange.

crawler_user_agents:
    default: 'Googlebot|Mediapartners|AdsBot|curl|HTTrack...'

You have changed something in: crawler user agents
/admin/site_settings/category/all_results?filter=crawler_user_agents


#8

that’s right :slight_smile: I don’t need crawler on my instance. How does this affect the css?


(Evgeny) #9

This information is required so that search engines can see the site as it is now. I.e. in “Lite” form. I think you can return the settings back, and users will see its normal form.

Сould say it’s a different version of the website. Search does not see the site as users see it via browser, even if you disable all scripts.


#10

Yep. I understand but I’m the founder of this instance. I can’t go back from the graphical interface because hamburger menu, avatar and search bar are gone.

Where do I have to search to modify crawler settings?


(Evgeny) #11

Maybe at this address:
https://m***.org/admin/site_settings/category/security

I no longer know any other ways.


#12

Empty :confused: There’s nobody on the forum actually. I will install it again. Not a problem. I’m gonna search on the database too before


(Rafael dos Santos Silva) #13

Follow this to fix it.

This is the second user to break discourse with this setting, I think we need to move it to a hidden site setting :thinking:


#14

that’s a tips :slight_smile: many thanks all is fine now


(Jeff Atwood) #15

Agreed @techapj can you make it so here?


(Arpit Jalan) #16

Done via:


(Jeff Atwood) #17