Merge Users borked?

After successfully updating my discourse installation from beta 2.7 beta 2 to 2.7 beta 3 just now, I tried a ‘merge users’, for a user who has only made 270 odd posts between his two accounts.
45 minutes later, website is still greyed out and showing ‘Changing post ownership’ - I assume some process has hung somewhere?.

My forum had otherwise very little activity going on (no other logged in users)

On searching this forum for clues, I stumbled across a post referring to the Merge Users plugin that ‘may be broken soon’ now that Discourse has included the functionality natively (as of Discourse 2.5.0 beta 3).

I still have that plugin (version 0.1) installed, though I did not as it happens initiate a merge from the plugins menu, but used a ‘Merge’ button found directly on the user’s profile page (bottom right). I am guessing this means I invoked the native Discourse tool rather than the plugin?

I am unsure whether the plugin or Discourse itself is to blame for the process stalling.

I can access the site as administrator using another browser session, and can see both profiles are still present, although all but 9 of the old posts being merged are now associated with the newer intended account. Beside that figure, I see a warning that may or may not be associated with this specific attempted merge process 'Can't delete all posts. Some posts are older than 60 days old. (The delete_user_max_post_age setting.)'

As it happens ALL of the posts successfully merged were older than 60 days, so unsure what to make of this.

What do I do now to elegantly terminate the process (assuming it is still ongoing) and prevent database corruption?

1 Like

OK, I gave up and refreshed browser window that was greyed out, and the site resumed as if nothing had happened - showing the same old version user account with the 9 unmerged posts remaining.

I tried again, after setting delete_user_max_post_age to 99999 - same result. I then tried merging the other way - same result.

In the end I tried again using the plugin, and this worked perfectly first time, and took only a minute or two.

So, on the evidence at hand, the 2.7 beta 3 Discourse merge function is broken in some way, but the plugin still works.

I works fine when I try it. Maybe there was something going on because you had the plugin installed? On here it is categorised as a #plugin:broken-plugin. Glad you fixed it eventually.


Thanks. I will uninstall the plugin, on the basis that if the situation is not improved next time for native merge process, I can always presumably reinstall it.

I wonder if the age or source of the posts being merged was a factor? These posts were all imported from a now defunct Yahoo Groups forum, and the import process created ‘zombie’ users where there was no corresponding active user for the given email address already. I think this old user account was an example of this.