Sto ricevendo lo stesso errore a causa di 3 post ![]()
Aggiornamento degli URL nel database...
Avviso: nessun cast di tipo definito per il tipo "name" con oid 19. Si prega di castare esplicitamente questo tipo a TEXT per essere sicuri in caso di futuri cambiamenti.
Rimozione delle immagini ottimizzate vecchie...
Segnalazione di tutti i post contenenti lightbox per la rigenerazione...
123456 post sono stati segnalati per una rigenerazione
rake aborted!
FileStore::ToS3MigrationError: 3 post non sono stati mappati al nuovo URL di upload S3. Migrazione S3 fallita per il database 'default'.
/var/www/discourse/lib/file_store/to_s3_migration.rb:131:in `raise_or_log'
/var/www/discourse/lib/file_store/to_s3_migration.rb:86:in `migration_successful?'
/var/www/discourse/lib/file_store/to_s3_migration.rb:357:in `migrate_to_s3'
/var/www/discourse/lib/file_store/to_s3_migration.rb:65:in `migrate'
/var/www/discourse/lib/tasks/uploads.rake:245:in `migrate_to_s3'
/var/www/discourse/lib/tasks/uploads.rake:224:in `block in migrate_to_s3_all_sites'
/var/www/discourse/vendor/bundle/ruby/2.7.0/gems/rails_multisite-2.5.0/lib/rails_multisite/connection_management.rb:76:in `with_connection'
/var/www/discourse/vendor/bundle/ruby/2.7.0/gems/rails_multisite-2.5.0/lib/rails_multisite/connection_management.rb:86:in `each_connection'
/var/www/discourse/lib/tasks/uploads.rake:222:in `migrate_to_s3_all_sites'
/var/www/discourse/lib/tasks/uploads.rake:218:in `block in <main>'
/usr/local/bin/bundle:23:in `load'
/usr/local/bin/bundle:23:in `<main>'
Tasks: TOP => uploads:migrate_to_s3
(Vedi la traccia completa eseguendo il task con --trace)
@gerhard - Se riceviamo un errore del genere, sai se il significato è “successo! - tranne che per 3 post” o “fallimento grave della migrazione, a causa di 3 post”?
Per tentare di riprendere, dovrei eseguire di nuovo rake posts:rebake, rake posts:rebake_uncooked_posts o rake uploads:migrate_to_s3?
Apprezzerei qualsiasi aiuto ![]()