Missing field mainEntity.acceptedAnswer.text

Hello. Currently, we are getting this message in our Google Search Console. I’m not entirely sure what it means, but I feel it’s related to the solved plugin. Can I get more insight on what this is? A fix?

Are the running the latest solved plugin code? There was an update just over a week ago to fix support for Q&A structured data.

When I check random pages here on Meta, there are no Q&A page errors. If the topic is solved, Q&A shows no errors. If the topic is unsolved, it shows an error that there is no acceptedAnswer (as you’d expect). If the topic is in a category without solved enabled, Q&A type doesn’t show up in the structured data test.

Once you’ve confirmed that you’re fully up to date, if it’s still showing errors we’ll need to see one (or more) of the URLS giving errors so we can look into it.


I brought this to their attention and we are going to go through the process of updating it. Thank you!

1 Like

Let us know how you turn out, we do want to fix it if there’s something wrong here!

1 Like

I just got that email today:

Where you able to solve it? @Kampfkarren

I’ll ask you the same thing as Boyned//Kampfkarren, can you share a one of the URLs Google is erroring on? Can you confirm that your site (and the solved plugin) are up to date?


Sorry, red tape means that it’s hard for me to know if we’re updated or even if we’re still getting it, I’m just echoing what I’m being told. I’ll ask my team.

This file contains URLs for error Missing field ‘mainEntity’
https___community.kodular.io_ Q&A Issue Drilldown 2019-01-28.csv (4.6 KB)

This file contains URLs for error Missing field ‘mainEntity.acceptedAnswer.text’
https___community.kodular.io_ Q&A Issue Drilldown 2019-01-28 (1).csv (179 Bytes)

You did not answer the second question:

Yes, it is
Made a rebuild from SSH on Friday


Hey Diego,

Are you still seeing these errors? I’ve kept an eye on this, and cannot reproduce it.


I haven’t heard anything, so I’ll assume yes. Thanks!

I got the email today

This is the URL Google is reporting with error

1 Like

I have the same issue now.
Now I’m running v2.4.0.beta4 +12. :thinking:


The answer post is entirely a oneboxed URL, and the “Solved” box in the first post also has no text (which is what the error is complaining about).


I looked this up and Google is complaining about one, and exactly one URL here on meta:


That’s the one where it says

Q&A > Missing field “mainEntity”


Just received this email too! I’m on latest Discourse version and latest solved.

@jomaxro are you still accepting URLs to look at?

I’m not personally looking for URLs anymore, no, but the team would certainly happily accept them! You can reply with them here, or shoot them in a PM to @team if private (be sure to link to this topic in your message if you do that so they have context).