Missing uploads, no tombstone recovery


#1

I’ve been having trouble with user uploads disappearing. After reading various posts like this one:

I tried upgrading to the latest version of Discourse planning on then using the recover_from_tombstone script.

Note incase it’s applicable: I also had a ton of failed sidekiq tasks due to email setup issues. As we don’t want the site sending any emails I turned that feature off via the admin console, and then ran the task to flush redis.

After all of this I tried to recover from tombstone. It does nothing:

rake --trace uploads:recover_from_tombstone
** Invoke uploads:recover_from_tombstone (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute uploads:recover_from_tombstone

However, if I run uploads: missing there is a large list of missing items.

Any suggestions?


(Curtis Rueden) #2

@Hewitt I am no expert, but a little more information might be helpful to the Discourse team. For example, did you check whether the uploads are still present in the tombstone, like I described in my post?