Images lost after restore from backup (very old discourse install)

I had an old ubuntu host that I didn’t feel like upgrading to ubuntu 18.

I followed the new host setup steps, then restored.

The site is up & going, but images seem to be missing.

All the files seem to be in the tombstone, but rake uploads:recover_from_tombstone doesn’t seem to help (nor does it fail with any error)

Rebuilding HTML on an individual post doesn’t work.

What could be done to get the images showing again?

The domain name did not change?

I’ve just had a heck of a time with this… and can confirm that this command was never run:

 rails c
[1] pry(main)> OnceoffLog.where(job_name: "RecoverPostUploads").count
=> 0

How were we supposed to know to do this?

You weren’t supposed to do this by hand.

Try

rails c
OnceoffLog.where(job_name: "PostUploadsRecovery").count
2 Likes

At this point, It’s

# rails c
[1] pry(main)> OnceoffLog.where(job_name: "PostUploadsRecovery").count
=> 1
[2] pry(main)> 

Before I ran rake posts:missing_uploads the output of OnceoffLog.where(job_name:"RecoverPostUploads").count was 0

Note that the job name is different here so running the rake posts:missing_uploads didn’t change the count.

2 Likes

Got it, yes, OnceoffLog.where(job_name: "RecoverPostUploads").count is still 0

I’m looking at a way to push up every file from the backup I’m using.

This issue was ultimately solved in

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.