Mixed content problem

I am running into a weird mixed content related error when serving discourse using a digitalocean droplet:

digitalocean / cloudflare is handling the SSL part, so this is not configured via Discourse or an nginx based reverse proxy. nginx simply forwards incoming requests to the Docker container running Discourse:

server {
        listen 80; listen [::]:80;
        server_name mysite.org;

        location / {
                proxy_pass http://unix:/var/discourse/shared/standalone/nginx.http.sock:;
                proxy_set_header Host $http_host;
                proxy_http_version 1.1;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_set_header X-Forwarded-Proto $scheme;
                proxy_set_header X-Real-IP $remote_addr;
        }
}

All assets seem to be loaded fine over https, excepts for this 1 file. By entering the app and searching the postgres database I’ve figured out that it is the file /images/discours.png that is causing the problem. I have tried deleting this file and any references to it in the postgres database in an attempt to just avoid loading this image all together, but obviously Discourse re-adds the image when rebuilding the app (at least, I assume it does).

Hopefully someone can give some advice.

1 Like

Is that a default site logo? Did you try uploading another one to override it?

2 Likes

Is that a default site logo

Yes, it is a file called discourse.png, so I assume it is a default site logo. In the db it always has an id of -6 (uploads table).

Did you try uploading another one to override it?

Yes, also tried that. Then the same problem applies to the custom, uploaded logo.

Hi there,

Any clues about mixed content problem?

I’ve followed this post recommendations, but the problem still holds!

Thanks in advance!

try and see if you can access that image in a new tab.

Once you know which picture it is, try re-uploading it.

If I remember correctly, I checked the force_https parameter and then upload a new logo.
https://your.domain/admin/site_settings/category/all_results?filter=force_https

2 Likes

Worked like a charm! Thank you so much!

1 Like