Moderators no longer see new flagged posts

(Guido Drehsen) #1

we are on v2.3.0.beta6 +175 but the problem started already earlier, somewhere at +30 or so.
Our admins (like myself) do get the red numbers and do see the flagged post but our moderators do not get the red numbers for flagged posts anymore and do not see the flagged posts.
So something is strange with the rights if only admins can see them.

(Sam Saffron) #2

@eviltrout has deployed a new feature called the review queue see:

Assigning this to Robin who can test out if something changed where only admins get notification and not moderators.

2 Likes
(Guido Drehsen) #4

additional information: queued post that have to be approved the moderators do see and also user to be approved are visible to the moderators, both under the “Needs review” button.
It is just the flagged posts were they do not get information and do not see them under “Needs review”.

(Jay Pfaffman) #5

I’ve got a site where people are complaining that they get notification that there are things to review but see nothing in the queue. (I haven’t updated in a few days.)

(Robin Ward) #6

I can’t seem to reproduce this locally. I tried with a moderator and flags were visible. I also checked the code path and it has the reviewable_by_moderator flag set to true. The only thing I did find is that old migrated flags were not given this flag. Can you confirm these are new, incoming flags? Do you have any other information, such as the type of flag or who created them?

3 Likes
(Yaw Anokwa) #7

We also have this issue on our forum. We have a notification and if I go into the review queue, grouped by topic has no items, but view all has one topic. If it helps, it’s an Akismet Flagged Post and looks like it was from two days ago and I upgraded about seven days ago.

This is what I see…

41%20AM

(Guido Drehsen) #8

well it is a post that was flagged already twice in the past and that was now flagged again.
Type of flag is “inappropriate” and it was created by a normal user with trust level 1.
This is how is look like for an admin like myself.

And the moderator do not see this at all.

Update: posts with new flags that had not been flagged before are visible for the moderators.
We just got two of them and they do see them both.
So it has something to do with the fact that it was already flagged in the past.
Nevertheless the moderators should also see the new flagging of posts that had already been flagged in the past.

another Update:
I did just the migration to v2.3.0.beta7 +1 but the problem remains.

(Robin Ward) #9

Hi @yanokwa is there any chance the flagged post is below your min score default visbility? I’m also wondering if perhaps the topic was deleted.

(Robin Ward) #10

Aha if the flag existed before I fixed the old migration that explains it. A “Reviewable” is re-used if someone else flags the same thing. Viewing permissions are set on a “Reviewable” basis so those old ones that were migrated incorrectly will not show up for moderators if the content is flagged again.

There is an easy fix if you can jump into a rails console:

ReviewableFlaggedPost.update_all(reviewable_by_moderator: true)

You should only need to do this once - new flags have the correct permissions.

2 Likes
(Yaw Anokwa) #11

@eviltrout min score default visibility is 0.0 and I think this post is 6.0, so no. Definitely possible that the post was deleted. How do I check? I’m comfortable on the command line if you wanna send me to the rails console.

(Guido Drehsen) #12

thanks that worked fine, now they are visible to the moderators.