New installation on Fedora 23 - FAILED RuntimeError: cd /var/www/discourse && su discourse -c


(Philip Rhoades) #1

People,

I am trying to do an installation on a new DO server with Fedora 23 x86_64 but get a long way into:

./launcher bootstrap app

before it finally stops with:

FAILED
--------------------
RuntimeError: cd /var/www/discourse && su discourse -c 'bundle exec rake assets:precompile' failed with return #<Process::Status: pid 1290 exit 137>

I found only one mention of this for a guy who was trying to install on CentOS and he gave up and used something else . .

Suggestions?

Thanks,
Phil.


(Régis Hanol) #2

I’m afraid Fedora might not be supported. Does it support the latest version of Docker?

Anyway, why don’t you use the recommended Ubuntu? It’ll be much easier.


(Jeff Atwood) #3

Make sure Docker is installed correctly. What does docker info and docker version report? That’s critical.


(Philip Rhoades) #5

Containers: 0
Images: 6
Server Version: 1.9.1
Storage Driver: devicemapper
Pool Name: docker-252:1-787310-pool
Pool Blocksize: 65.54 kB
Base Device Size: 107.4 GB
Backing Filesystem: xfs
Data file: /dev/loop0
Metadata file: /dev/loop1
Data Space Used: 1.538 GB
Data Space Total: 107.4 GB
Data Space Available: 28.62 GB
Metadata Space Used: 1.606 MB
Metadata Space Total: 2.147 GB
Metadata Space Available: 2.146 GB
Udev Sync Supported: true
Deferred Removal Enabled: false
Deferred Deletion Enabled: false
Deferred Deleted Device Count: 0
Data loop file: /var/lib/docker/devicemapper/devicemapper/data
Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
Library Version: 1.02.107 (2015-09-05)
Execution Driver: native-0.2
Logging Driver: journald
Kernel Version: 4.2.3-300.fc23.x86_64
Operating System: Fedora 23 (Cloud Edition)
CPUs: 1
Total Memory: 993.5 MiB
Name: philsdoms3
ID: EP3H:QFNK:4ORJ:ICRC:PPK7:JEYQ:3D5S:USWE:Z4NQ:SCKD:5WS6:SRXH

Client:
Version: 1.9.1
API version: 1.21
Package version: docker-1.9.1-6.git6ec29ef.fc23.x86_64
Go version: go1.5.3
Git commit: 7206621
Built: Mon Jan 25 20:52:22 UTC 2016
OS/Arch: linux/amd64

Server:
Version: 1.9.1
API version: 1.21
Package version: docker-1.9.1-6.git6ec29ef.fc23.x86_64
Go version: go1.5.3
Git commit: 7206621
Built: Mon Jan 25 20:52:22 UTC 2016
OS/Arch: linux/amd64


(Jeff Atwood) #6

Devicemapper is non starter, fails spectacularly under load and causes corruption. We block setup if we detect devicemapper. You need aufs or another better supported docker filesystem.


Error when launcher bootstrapping (Permission denied)
(Re)Installing Discourse with Docker on CentOS 7
(Philip Rhoades) #7

I just tried installing on my personal Fedora 23 x86_64 workstation and it worked fine there - OK, I will have a look at the differences between the two setups and your suggestions.

Thanks!
Phil.


(Philip Rhoades) #8

Was:

device-mapper-multipath-0.4.9-80.fc23.x86_64
device-mapper-multipath-libs-0.4.9-80.fc23.x86_64

but installing them as well did not help but at least I got a different error message and I then I realised there was no swap on the new DO server so I created a 2Gb swap file and then everything installed OK!

Thanks,
Phi.


(Jeff Atwood) #9

Devicemapper will corrupt your install over time. We block install on devicemapper for that reason.


(Philip Rhoades) #10

I found instructions here:

but I have not had to build a kernel for many, many years - I think I am well past that interest . .

This:

says:

‘aufs was rejected merging into mainline Linux. Its code was criticized for being “dense, unreadable, and uncommented”.[3] Instead, OverlayFS was merged in the Linux kernel [1][4] After several attempts, the author has given it up’

which does not give me any enthusiasm for aufs either . .

P.


(Jeff Atwood) #11

Then use overlayfs, but if you use devicemapper your docker filesystem will randomly corrupt. If that is your idea of a good time, go for it. Have fun.


(Philip Rhoades) #12

Are you saying this is a general comment wrt to docker or just docker + discourse? I have only been using docker lightly so far but have had no problems . .


(Sam Saffron) #13

Device mapper issues have nothing to do with Discourse.

Redhat team get very upset when we mention that it just does not work for us, but release after release they say there are no bugs left, and each time we keep seeing Discourse users complain about corruption due to device mapper.


(Philip Rhoades) #14

Then you didn’t really answer my question - do any non-Discourse Fedora users see this problem?


(Kane York) #15

Just set the Docker daemon to use overlayfs, it works just fine.


(Philip Rhoades) #16

@riking,

OK, I will have a look at that but I still haven’t had an answer to my question . .

Thanks,
Phil.


(Sam Saffron) #17

No idea but plenty of bug reports in Docker’s issue tracker Issues · moby/moby · GitHub


(Philip Rhoades) #18

@sam,

OK, thanks.

Phil.


(Kane York) #19

It’s probably this bug, devicemapper seems to be unable to free deleted files until you delete the container: Delete data in a container devicemapper can not free used space · Issue #18867 · moby/moby · GitHub

Which is catastrophic for any long-lived server that uses temporary files in any capacity at all.