Not Using A Supported Storage Driver

unsupported-install

(Owen Sullivan) #1

Here’s the issue @codinghorror @mpalmer

I’m installing Discourse on Ubuntu, and I have Docker installed properly. But when I build the app.yml for the first time, it gives me the “Your Discourse is not using a supported installation driver”

I have already searched the forum and I found that I needed to add -s aufs to the docker.service file that I copied. But how do I restart Docker? When I do docker ps no containers are shown which means I cannot restart a container. Does this mean I have been installing wrong?

I have been using this tutorial:


(Eli the Bearded) #2

service docker restart


(Owen Sullivan) #3

Ah, thank you so much! Let me see if it works and if so I will mark the solution.


(Owen Sullivan) #4

That restarted Docker, but it didn’t successfully change the storage driver to aufs. It’s still stuck on vfs.


(Eli the Bearded) #5

Likely then you need aufs installed, not just enabled in the config.

It’s something like:

apt-get -y install linux-image-extra-$(uname -r) aufs-tools

Might need to reboot, or might need to just restart docker.


(Jeff Atwood) #6

Are you sure you installed following the official install guide? I have never seen this problem in hundreds of Ubuntu official guide installs. Did you deviate in any way on any step?


(Owen Sullivan) #7

I am using the install directions from DigitalOcean because it seems they are the same.

Also @elijah when I run that I get an error saying that it cannot find the package.


(Owen Sullivan) #9

I also tried running wget -qO- https://get.docker.com/ | sh and it told me to install two packages, but even after doing so it won’t run.

Is there any .deb I can use to install the entire package with aufs?


(Joshua Rosenfeld) #10

@sulliops, if you’re having difficulties, I’d highly recommend destroying your current droplet and follow the official Discourse install instructions: discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub. A quick look at the Digital Ocean tutorial shows that Docker is installed completely differently from the official docs.


(Hexa) #11

Hey!

I’m going to jump in for @sulliops. I’m the one he’s installing Discourse for. I found a tutorial on meta.discourse.org on how to install Discourse without Docker. So far, the installation is going well. Only a few more steps to go. I’m thinking Docker may be the issue causer. I’ll update you once the installation finishes.

Austin


(cpradio) #12

Be very cautious with that approach, as you are effectively doing an unsupported install.


(Hexa) #13

Once I get it installed, would it be the same as it would without Docker?


(Joshua Rosenfeld) #14

No it would not. We would not be able to provide any support for the install or issues afterwards.

I’ve done many installs on DO following the official guide, included one last night. Just follow the official guide.


(Hexa) #15

I’ll finish the install and see how stable the platform is after that. Then, if it causes issues, we will just scrap it and start with the official guide. Have people has issues using a non-supported installation?


(Matt Palmer) #16

Nope, it’s completely different in many, many important ways.

Only after they need support.


(Hexa) #17

What are the types of issues that could happen? Could I just do weekly backups or something to prevent data loss?


(Hexa) #18

My Installation:


(Hexa) #19

Don’t know if it would work though. Maybe? :confused:


(cpradio) #20

That is for a development environment, note the use of the word “development”, it does not say Production.


(Matt Palmer) #21

We don’t know, because it’s unsupported.