New Topic URL - Lost if not logged in


(Yyhmsg) #1

Continuing the discussion from Compose a new pre-filled topic via URL:

@techAPJ I was just exploring the new topic url and just tried clicking on a new topic url when not logged in - it then asks you to login which is great, however, after you are logged in you just go to front page - not to the new content window. So I don’t think this is fixed yet. As something else changed that makes the session variable not hold?


(Arpit Jalan) #2

I just tried visiting this URL when not logged in – Discourse Meta

The feature is working as expected for me, as soon as I provided my credentials, the pre-filled composer opened.


(Jeff Atwood) #3

Are you referring to SSO or regular login? Can you repro on try.discourse.org?


(Yyhmsg) #4

I had only tried sso (github and facebook if it matters…) - which does not work - a regular login does. I think I understand some of the complexity of this with sso logins, but this type of functionality would be awesome for my site at least. Is it possible with sso?

Oh, and I reproduced this on my site and on meta, but try. is not responding right now so I couldn’t try it there…


(Yyhmsg) #5

Just an update try. wasn’t down it just doesn’t work with https and you get a connection refused error… Either way, with that figured out I tried this on try. just now with

and it doesn’t work there either with sso…


(Jeff Atwood) #6

Try does not use SSO. Can you repro this @techapj?


(Arpit Jalan) #7

I understand your issue now. I can confirm that this feature is not working when logging in via social login method (Google/Twitter/Facebook).

Working on a fix now. Fixed via:

Thanks for reporting this @yyhmsg :gift_heart:


(Yyhmsg) #8

Awesome! Thanks for the quick fix! I’ll give it a shot at the next update of my site.


(Arpit Jalan) #9