Not able to log in after restoring a backup


I have a Communiteq hosted forum and another self-hosted forum, hosted on digitalocean. I took a backup of communiteq hosted forum today and restored it on my DO forum through the UI.

After that, I am not able to login to my DO forum. When I tried to opt for forgot-password option, I got “No account matches the username” error. Not able to log in through admin or any other user account.

This warning being shown on top of the forum:

Outgoing email has been disabled for non-staff users.

Tried going through other similar threads but could not find any solution.

I have enabled Google SSO login on both the forums. I have installed few extensions on my own on the DO forum. I do not know if either of them could cause this issue. Both the forums have different URLs.

Kindly help in:

  • Finding out the root cause of this issue
  • Logging into the DO forum
  • Knowing what happened during the restore (log) and if command line method is better than UI


Hello and welcome @A_A :slight_smile:

When you restore a backup disable emails is set to ‘non-staff’ so all of your users won’t be bombarded with any notifications, and when you’re ready you can then flip the setting to allow emails to everyone again (which should explain the info banner you’re seeing).

Now the backup has been restored, you should be able to login as your account from the restored site (so not the one that was there previously, if it was different). It should be exactly the same as the one that was on Communiteq.

Is this not the case?



As I mentioned in my original post, I am not able to log in through my admin account and other fellow users are also facing the same issue. Below is the error:

Incorrect username, email or password

It is not even able to recognise the email id / user name for all users.

So need help in fixing this.

1 Like

Sounds like something went wrong with the restore. I’d probably try it again from the command line. And then something like

./launcher enter app
rails c
User.all.pluck(:username, :id)

To see if you have the users you expect (you could try that before you do the restore again)


Thanks for your support. Looks like I was trying to log in through my old user base. When I run this command, I found the list of users and it worked fine afterwards.

Thanks once again. Next time, I will do it through command line.


That command just shows the users and doesn’t change anything. Though I prefer command line restore in most cases, it works exactly the same.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.