Not able to log in with Google token

When people try logging in with Google they get this error:
“When Unable to verify authorization token due to server clock differences. Please try again.”
I’m not sure how to correct the clock. Also how to keep it correct. It was correct two days ago.

What hosting service and what OS are you running on?

Try running ntpdate and see if it reports a correction, or systemctl restart ntpd.

Ensure that your server timezone is set to UTC.

2 Likes

Hi. I am on UpCloud running Ubuntu Server 20.04 LTS (Focal Fossa).

Here is the log of what you suggested

Noticed now that it’s not installed. I installed it and it says “no servers can be used, existing”

You might try searching more broadly as you have a systems administration issue rather than a Discourse one. Or maybe open a ticket with upcloud.

1 Like

Yeah, do a more general search or talk with your provider about how to fix your clock

2 Likes

@Eysteinn_Gudni ntp is corrupt , try to remove ntp then install again

  1. /etc/init.d/ntpd stop
  2. update-rc.d -f ntpd remove
  3. sudo apt-get install ntp
  4. sudo systemctl enable ntpd

check status ntpq -p

2 Likes

It looks like that did the trick. Thank you!

2 Likes