Not valid SSL certificate WP discourse


(Jeroen Van Der Mark) #1

Hi! We are running the WP discourse plugin. Great integration btw! Thanks for that.

One small problem pops up: it loads the profile picture as http instead of https. (see: Kijkje in de keuken van Tom Wanders - FIT.nl)
This leads to an incorrect SSL-certificate. Is there a known fix for this?

Thanks in advance :blue_heart:


(Jay Pfaffman) #2

Are both sites https? Is force https enabled on the discourse side?


(Jeroen Van Der Mark) #3

Ah perfect, thanks for your answer! I forced it now in https (option was off). Still a http result, maybe cache?

Both sides are https :slight_smile:

https://forum.fit.nl & Kijkje in de keuken van Tom Wanders - FIT.nl


(Simon Cossar) #4

Do you have the https URL set in the Discourse URL option on WordPress? It is used for converting any relative URLs that are returned from Discourse to Absolute URLs.


(Jeroen Van Der Mark) #5

Thanks Simon! Yes i have the |Discourse URL| -> https://forum.fit.nl


(Jay Pfaffman) #6

I checked and when I look at an avatar on the WP side, I get an https link to the discourse avatar.


(Jeroen Van Der Mark) #7

That’s correct :slight_smile:
But the image is still http source instead of https.


(Jay Pfaffman) #8

Oh. You’re right. I swear that I’d seen an avatar/profile image as https, but now I’m seeing http.


(Simon Cossar) #9

The src attribute for the avatars is set by the data that’s returned by Discourse. If you have setup a webhook for syncing comments between Discourse and WordPress, you will be getting comment data that has been cached on WordPress until a new comment is added to a topic. Hopefully that’s the problem. Let us know if this doesn’t get resolved.


(Jeroen Van Der Mark) #10

It works :slight_smile:

Thanks @Simon_Cossar & @pfaffman for the great help :blue_heart: