Why are the avatar images coming up http for WP Discourse?


(Andrew Shanahan) #1

Hi all - we use WP Discourse on our site and we’re getting some SEMRush errors around the fact that the avatar images are linked as http whereas the username link is https

Our site has always been https (as far as I know) and I can’t understand why the avatar images wouldn’t be as well.

Anyone know what I need to do to fix?

You could see a sample of this at 15 NEW MAN v FAT Football leagues for January 2018! | MAN v FAT


(Vinoth Kannan) #2

Did you enabled force https in site setting?


(Andrew Shanahan) #3

Ahhh, good spot - no I didn’t. I don’t like to force anyone to do anything, because I’m such a nice guy.

Actually, it’s not that at all, I was just spooked by the hardcore warning.

Force your site to use HTTPS only. WARNING: do NOT enable this until you verify HTTPS is fully set up and working absolutely everywhere! Did you check your CDN, all social logins, and any external logos / dependencies to make sure they are all HTTPS compatible, too?

That’s a very butch phrase. We have https set up so am I safe to enable this then?


Unwanted space keep comming up for random post
Unwanted space keep comming up for random post
(Bhanu Sharma) #4

Yes, if your ssl is configured properly then you’re safe doing that.


(Andrew Shanahan) #5

Sweet, I’ve ticked the box and we’ll see what happens next.


(Bhanu Sharma) #6

If you’ve checked the box and your forum loads correctly, That’s all that was supposed to happen. No surprises :tada:


(Andrew Shanahan) #7

That’s amazing, thank you internet stranger for your kind help.

How could I get the Wordpress pages to “look at” the forum again and see that they images are now all using https?

EDIT: Huh, just checked and it appears that they’re already updated. What witchcraft is this!


(Bhanu Sharma) #8

That’s the Discourse’s secret sauce :fireworks:


(Andrew Shanahan) #9

Thanks again - really helpful!