Port 80 appears to already be in use


(Цунский Никита) #1

Hello, when i run discourse_setup, it says Port 80 is used. Maybe there is something hosting installed by default, so I want to clear port 80 successfull instalation.

Port 80 appears to already be in use.

If you are trying to run Discourse simultaneously with another web
server like Apache or nginx, you will need to bind to a different port

See https://meta.discourse.org/t/17247

What I must to do to clear this Port from anything what is using it. If it would help - I’m trying to install Discourse here 185.145.253.103 (index.html appears, so something is using port 80. I’m not sure what)


Can anyone install discourse for me?
(cpradio) #2

Just running uninstall comands for apache, nginx, lighttpd to see which one removes it, that should clear it up for Discourse once any (or all) of those are removed.


(Mitchell Krog) #3

You can also just edit whatever web server is running on your server and just change it’s port to something obscure like 9900 so it can’t interfere but best as suggested by @cpradio is to just uninstall it if you never intend using any other web server


(Цунский Никита) #4

@cpradio @mitchellk
Soved by deliting apache and nginx, bu when i go to next step appears this problem


(Mitchell Krog) #5

Please post your app.yml here for us to see


(Stephen Chung) #6

I hit on this same problem, on an Ubuntu 17 VM.

Any idea how to disable the default application on port 80?

A list of commands to type will be nice, as it has been decades since I administered a Unix/Linux machine…

I used apt-get remove to remove apache*, nginx* and lighttpd, but it still says the port is in use.

EDIT: Got it to work. Turns out tcp6 was still listening on port 80. Rebooting the VM made it go away, and I was successful in installing Discourse. Thanks!