Preview of post not loading because force https was not set


(T. H. Wright) #1

On writing a new post or editing an old post, the editor is not showing the preview of a post. The option to hide the preview still exists; similar topics continue to load as normal.

I have been trying to track down what the source of this issue is but haven’t found it yet. I have reproduced this on my machine, in different browser, and other on a quite different network.

Recent changes to the install include:

  1. Updating from 1.8.9 to 1.9.0 and then to 1.9.1
  2. Installed the following plugins.
  1. Enabled Google OAuth
  2. Enabled comment embedding for the site’s associated blog
  3. made some adjustments to the headers by loading in some scripts and CSS. (Found at: How to display "Discord Widget" in a dropdown button)

Wondering if perhaps something went wrong in the previous rebuild when installing the plugins, I tried to rebuild the container without any changes, which resulted in the same behavior.

I have disabled the above plugins, removed the new header scripts, and rebuilt the container, but the editing preview continues to not load.

I searched through the settings but couldn’t find an option that seemed pertinent.

The docker install is running on an Ubuntu 16.04 server, Docker version 17.05.0-ce, build 89658be, plenty of disk space is available, and no heavy resource usage is being logged. The docker install is being proxied to by an Nginx 1.13.8 install.

I am wondering if there is something I have missed. If I can provide any further information, please feel free to let me know! Any help would be appreciated!


(Sam Saffron) #2

Try: How to use Discourse Safe Mode that would be my first go.


(T. H. Wright) #3

Everything disabled, no change. Any other pointers? :slight_smile:


(Sam Saffron) #4

Look at chrome dev tools, what is the error, are any assets not loading?

If you are running an HTTPS site, be sure to tick force_https site setting.


(T. H. Wright) #5

The site is running HTTPS; I could have sworn the option had been selected, but it was off. Turned it on, no change.

Only errors in console are for Google Analytics, but that is being blocked at the network.


(Sam Saffron) #6

hmmm, I would try restarting browser that may have a 404 cached and even doing another rebuild.


(T. H. Wright) #7

The rebuild got it that time. I’m seeing the previews now. Hmm…

Thank you, @sam! Appreciate it. Time to test until it breaks :wink:


(Jeff Atwood) #8