Problem with https with favicon in onebox

(Vaping Community) #1

Ok, so I have my site setup with SSL and it works great, images are downloaded from sources to preserve HTTPS but in an external link onebox the favicon.ico will not / can not download? And is breaking the https.

(Jay Pfaffman) #2

Did you check in your settings to see if are referring to it as https?

(Vaping Community) #3

Sorry, to be clear, this is a onebox from a different site.

(Jay Pfaffman) #4

Oops! Sorry. It’s not one of my areas of expertise, but I’m guessing that’s a problem that can’t easily be fixed. The only way that I can see would be for Discourse to serve its own copy of those, which it does for most images unless that site setting has been changed.

(Vaping Community) #5

I have the setting set to download images which works great but it can’t work for .ico files?

(Rafael dos Santos Silva) #6

If you add .ico to authorized extensions it works?

(Vaping Community) #7

I’ll try now, thanks for the reply.

Edit: Happy Anniversary @Falco :tada:

(Vaping Community) #8

I’ve added the .ico am I right in thinking this will now download the .ico and serve it locally?

(Vaping Community) #9

Thankyou it worked :+1:

(Jay Pfaffman) #10

So perhaps .ico should be added to authorized_extensions by default and this is a :bug:?

(Vaping Community) #11

I guess your right, they were introduced into onebox in 1.9 I think

(Andreas Dorfer) #12

EDIT it looks like a topic related to Plugin "TopicListPreview"

Discussion: Topic List Previews

these favicons “from http-only websites” are getting disturbing now with current chrome/firefox.

in other words: $USERS are complaining about “why is forum inscecure”
Off course i do explain, what “mixed content” means. But out of 2 which complain (where i do explain) there are probly 10 who do NOT complain, but just assume (silently) "discourse-forum=insecure"

and this even happens on the front page of the forum, where there is no onebox visible. (i do not know the background, but the requested URLs are favicons from oneboxes deep down in some threads.)

(Jeff Atwood) #13

Could you verify the above @techapj?

(Vaping Community) #14

The site does show as insecure until the image is downloaded by discourse, not sure if there is a way around it…

(Andreas Dorfer) #15

discourse doesn’t seem to download favicons due to size? or “copyright contstraints”?
(I am just speculating.)

(Vaping Community) #16

Add .ico to your allowed extensions and discourse will download them but it does take time to download, it is not instant

(Andreas Dorfer) #17

I tried this about 14 hours ago and started a full rebake (which finisched successfully meanwhile)


But no change, even after multiple Reloads:

Any hints?

(Vaping Community) #18

Not until I can get to my laptop…

Btw your header is broken on iPhone SE

(Rafael dos Santos Silva) #19

You are using custom plugins.

Safe Mode Discourse gets the green padlock: Freifunk Forum

(Andreas Dorfer) #20

You nailed it. thank you.

as edited above:

It looks like a topic related to Plugin “TopicListPreview”

Can you move it perhaps to Topic List Previews
(because my issue is NOT related to onebox)