Problems with libv8-node on installation

Hello Discourse Team,
I currently try to install my developer environment on my Raspberry Pi 4B

It says when I am trying to start the rails server

Ive already tried installing it via gem and bundle it says the installation succeed but when I am trying to start the rails server it failed again with the same Error.

Which model of Raspberry Pi it is? (E.g. 2/3/4)

Raspberry Pi 4B with 8 GB Ram

What OS are you running on your Raspberry Pi4? Is it the 64-bit version?

1 Like

Raspbian/Debian 64bit Version

I have fixed the first error with libv8-node.

It was because I was forcing the config to use ruby.

The Problem now is that I need glibc required by nokogiri to use discourse dev


rake aborted!
LoadError: /lib/aarch64-linux-gnu/ version GLIBC_2.29' not found (required by /home/pi/.rbenv/versions/2.7.6/lib/ruby/gems/2.7.0/gems/nokogiri-1.13.6-aarch64-linux/lib/nokogiri/2.7/ - /home/pi/.rbenv/versions/2.7.6/lib/ruby/gems/2.7.0/gems/nokogiri-1.13.6-aarch64-linux/lib/nokogiri/2.7/ /home/pi/discourse/config/application.rb:21:in <top (required)>’ /home/pi/discourse/Rakefile:7:in require' /home/pi/discourse/Rakefile:7:in <top (required)>’ /home/pi/.rbenv/versions/2.7.6/bin/bundle:25:in load' /home/pi/.rbenv/versions/2.7.6/bin/bundle:25:in ’ (See full trace by running task with --trace)

How can I install it?

Here are the news:

I tried installing Librarys ending up destroying my raspian.

know I reinstalled to Raspian 22 64bit

And it worked after updating node!!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.