Problems with the new-user webhook

Continuing the discussion from Discourse Webhooks and Zapier:

I want to get notified for every new user which is created in our forum.

The setup is below, and my forum is configured as follows:

  • The public can view a few categories
  • Group membership is required to read most of the rest.
  • the public can sign up, and validate themselves as a new user without any human interaction.
  • There is an SSO signup button which uses our main SaaS app for SAML authentication, and it will automagically apply the Group membership we wanted.

When I setup the webhook with just “User Event”, no ping was sent.

When “Post Event” was checked, I did get a webhook with data about the new user (recipient) and the sender of the welcome email.

How else can I troubleshoot new user creation’s webhook sending?

1 Like

Any ideas here for troubleshooting @tgxworld?

Can I clarify if you tested the “ping” action or do you mean that user events are never sent?

I have had an issue before where as new user events are not sent but edited user events are. As per here

Have not revisited it since

1 Like

Correct… I should have said “no webhook was sent”

I can use the ping feature, and zapier sees the ping just fine. I did see an event sent for the welcome message.

I didn’t see a new user webhook on either of the new users I tried.

I guess there’s a bug here:

  • A user self registering did not send a webhook.

  • There was no Approval needed in this forum. I think it should be tested to fire with & without an approval step.

  • Suspending & re-activating the user did not send a webhook.

  • Editing the user’s title did generate a webhook, and Zapier handled it well. :fireworks:


Are you sure this isn’t because of your SSO?

1 Like

The user I tested with signed up with a username & password. I don’t think think so.

We’re using a SAML Login button from

we don’t use traditional SSO


I feel like this is a bug @tgxworld – why would the new user webhook not fire?

Thanks for reporting @watchmanmonitor :slight_smile: Fixed in

Do upgrade to latest and let me know if this fixes it for you :slight_smile:


updated my test environment and built some new webhooks into zapier and seems to work well thank you for that!

As i believe it was something that fantasticfears was working on as part of the original webhooks pull request that was open - is it possible to get the email address included as part of the payload.



Confirmed, I updated to latest this morning, and about 20 minutes later, had a new user register. The webhook fired & my zap worked great.

EDIT moved the feature request to a new thread


I just tested with the SAML plugin, and with a normal user/pass account.

The best part here is that the webhook is sent at user registration, even before they confirm their address (or forget to…)

Now I can proactively track down people who try to get in, but never finish.