ProCourse Installer - Installing/removing plugins via the UI

So, would it be worth removing my existing plugins from the app.yml file and moving them to this installer?

1 Like

I have to admit that I’m conflicted on this one. It would really cool to be in core but if it’s in core, installing plugins will only work on Docker installs and non-multisite installs. That would cause problems for a quite a lot of instances.

Technically, it doesn’t matter. They end up being installed in exactly the same way. This just makes it easier to do.

8 Likes

I assume the challenges associated with getting it to work with multisite are far more complex then getting to set up multisite (which none of my clients have deployed) and I’m saying that from managing over 2 dozen active discourse installations.

It should be easier to include this in the standard app.yml on bootstrap for the standalone installs and not including the same in a multisite/multi container/HA setup.

It could always be part of core (with a big warning label that says “only works with docker”) but leave the current install method available as well.

Even better if there’s a way to detect a compatible installation and hide or show itself as necessary.

5 Likes

The main challenge is precompiling assets and such. We’re effectively adding the repo to the /plugins and then running an docker manager upgrade on that specific plugin. That handles the magic side of it.

But in a multisite, you run into issues because you don’t want one instance to be able to make edits for all instances in the multisite.

6 Likes

How i can uninstall a plugin using ssh? Because i installed Moderator Extension and now I cant put it anymore online, Error 502

Assuming you can’t get to the admin panel:

  1. SSH into the server.
  2. cd /var/discourse
  3. ./launcher enter app
  4. vim /shared/tmp/procourse-installer/plugins.txt
  5. Remove the offending plugin from the file.
  6. exit
  7. ./launcher rebuild app
4 Likes

Cant up online :cry:

Looks like your container isn’t running. Try this ./launcher start app

3 Likes

Thank You, my error 502 now are resolved. :smiley:

2 Likes

I think the installer is working fine but I saw this in my error log, not sure if it’s anything but thought I’d might as well bring it up:

NameError (uninitialized class variable @@install_state in ProcourseInstaller::InstallController)
/var/www/discourse/plugins/procourse-installer/app/controllers/procourse_installer/install_controller.rb:4:in `status'
2 Likes

Interesting. Do you have any guesses about what you were doing when that error came to be?

1 Like

Some 20 or so days ago, I installed this Procourse plugin, and another plugin (I forgot which one was it) thru this plugins interface.
After a few days, I found that many times (say once every few days) my website went dead slow. On those moments, even safe mode opening went equally slow. And after 20-30 minutes I found that the speed of my site became normal.

Although I have not got necessary skills to diagnose the logs, but since the logs’ (or was it sidekiq?) warning section contained ‘procourse’ so many times, I thought it is somehow related to this plugin installed inside/thru procourse plugin. So I uninstalled that plugin from procourse interface.

But yesterday it again (almost) crashed.
I checked and again found the word ‘procourse’ written in many many warnings in logs.

So today I decided and uninstalled procourse too.

Now my fingers are strongly crossed.

Can you share the backtrace of one of those errors? That would help us narrow down where it’s coming from.

1 Like

Since I have Uninstalled the plugin for the time being. I can have the logs sent only when next occurrence occurs.

(I don’t know if logs are kept for 2-3 days or not, if they are, then I can try).

Thanks.

I have been struggling with updating.
I have successfully done it manually, but it was nerve wracking for me. I am more a wysiwyg kinda user.
I am pretty sure that I successfully updated from the admin/upgrade page
But now it is locked up again.
Is it likely that this ProCourse solution will facilitate upgrading in the future?
Jay did my install so I can say with confidence it wasn’t a glitchy install : -)
This is what I am seeing;

I have just added a plugin through ProCourse Installer, which is causing some troubles on the forum. How do we remove it, if it doesn’t appear in app.yml?

Update: @Falco Just noticed the removing plugins guide. Thank you!

It might be that if you scroll down and upgrade docker_manager first, then upgrade all button will light up.

But, if you haven’t done a command-line rebuild in the year since your install, then you probably need to. See Automatic Rebuilds when They Are Needed – Literate Computing, LLC

(Oh, maybe I upgraded you in March and you should be OK.)

1 Like

We’ve been using ProCourse Installer for a while now. We tried installing the Force Sign-In and our members started reporting that the profile picture icon in the top right corner, as well as notifications won’t work. How do we get rid of this plugin, if it doesn’t appear in app.yml? Also, it won’t appear in ProCourse Installer - Installed Plugins, where we can usually remove them. Please help!

After installing a plugin through ProCourse, I’ve noticed I am not receiving any notifications. It’s also stuck on loading, while every other member receives them.

stuck

After closing this window, the avatar image is no longer clickable until I refresh the page.

I’ve uninstalled the plugin, and also tried safe-mode with everything disabled, but still experiencing this. /u/admin/notifications is empty.

When I receive a notification, thenotification icon appears on the avatar, but still won’t load.

Update: My 2nd account works fine, so I decided to merge both using this plugin and now I’m having the same issue with the target account. Could it be something in the account settings?