Publishing post to discourse not working

(Bob Christensen) #1

Error: Your post could not be published to Discourse. Check that your Discourse Username is set correctly on your WordPress profile page.

I have Just installed(1 week ago) and enabled SSO with WP as the provider. The sso is working but I get this error when trying to publish to Discourse. I’m not forcing the usernames to change to the WP username. However I have made sure they match on the writing account.

(Simon Cossar) #2

Can you double check the value of the Discourse Username field on your WordPress user profile page? It is in the profile page’s Contact Info section. The Discourse Username needs to exactly match your username on Discourse. Let me know if this doesn’t solve the problem.

1 Like
(Bob Christensen) #3

I don’t have a discourse Username field on the WP profile page.

(Simon Cossar) #4

Can you check if you have enabled the WP Discourse ‘Do Not Display Discourse Name Field’ option? It is found on the plugin’s Publishing tab. If this setting is enabled, could you try disabling it? That should let you see the value of the Discourse Username on their profile page.

If you have not enabled that setting, and are still not seeing the Discourse Username field, it is quite likely a conflict with another plugin. I can take a look at that.

2 Likes
(Bob Christensen) #5

Thanks for your help. I did have that box checked. Everything is working great now.

2 Likes