Quick Quote Theme Component

I don’t allow quoting whole post and still automatic one works. But I’m limiting quoted post, can it mean something?

Seems to be working, miraculously, after nearly ~2.5 years of no maintenance?! Appears so!

So currently agree with @JammyDodger … I don’t think this is your issue @danielabc

1 Like

This has received some :heart:

3 Likes

help! when I’m replying to the topic, it quotes the entire block of text from the original post

Hmmm … cannot repro I’m afraid, can you share you settings? Which button are you pressing?

2 Likes

Is there a way to differentiate between “reply to post” button that is on the original post vs. “reply to post” on all the comments/responses/replies to the original post?

And your settings … ?

OK so that makes sense.

No, hence partly why quick quote post location threshold is normally 3 I believe.

A quick workaround would be to set that to at least 1 which would block the last (and first post). The assumption is you don’t need to quote the very last post as it is right there in front of you.

tbh, I don’t quite understand why you are making a special case of the first post?

What is the real functional difference between always quoting and always quoting except the OP?

1 Like

I see, thanks!! - I’ll just change the threshold to make it more organized.

Just from the user’s perspective, sometimes they just click on the first “reply” button they see on mobile and then they end quoting the original post which isn’t necessary

i just changed the text on the bottom button to “Reply to Topic” and problem solved.

2 Likes

that’s a good workaround. thank you!!

2 Likes

here is the code for it

2 Likes

But surely that’s true for every post, not just the first one?

I really am not convinced quoting the very last post, wherever you are in the Topic, makes that much sense in any case? I would definitely set quick quote post location threshold to at least 1 as 0 is definitely wasteful of space.

1 Like

so good!!!

2 Likes

Looks like this component isn’t working as of the latest Discourse update. I had to disable it this morning on one of my instances because all my reply buttons stopped working (core was updated last night). @merefield

2 Likes

Just as an addition

3 Likes

As a free addon this is on my radar but not my first priority.

I will take a look soon.

2 Likes

This should be fixed. Let me know if you have any further issues:

@Festinger @JammyDodger

4 Likes

Thanks for the quick fix Robert :slight_smile:

1 Like