Rails server --daemon and plugins


#1

I’ve followed the instructions at Beginners Guide to Install Discourse on Mac OS X (macOS) for Development to install a development environment of discourse. I’ve also installed the discourse-solved plugin, and everything works when I run: bundle exec rails server.

I wanted to run discourse with rails’ built in daemon. However, when I run the command bundle exec rails server --daemon, the discourse-solved plugin no longer seems to function correctly. For example, the option to accept a post as a solution is no longer available.

Does anyone have advice on how to get the plugin working correctly as a daemon in this fashion, or whether or not I should forgo this daemon mode and find a better strategy?


(Rafael dos Santos Silva) #2

This happens indeed, but since I’m used to run a terminal multiplexer (tmux, byobu) I never found it myself.


#3

Ah! Nice! I was able to work around this issue with multiplexing, thanks!!


(Bill Wang) #4

yes, I got similar problem.
if run rails in deamon,
I got " uninitialized constant Jobs::BotInput" when post a new topic.


(Sam Saffron) #5

Yeah this is the reloader, it is not super plugin friendly, to say the least

When this happens you sadly have to stop everything and relaunch

@tgxworld we should probably put a hack in place to compensate for bot… what happens is the job base class gets reloaded nuking the bot input job which never gets reloaded.