Error after restarting the discourse


(Алексей Копаев) #1

Tell me, what could be the error?
After the restart, the discourse stopped running.
Logs can be seen by reference https://pastebin.com/DzUPNhAT


(Rafael dos Santos Silva) #2

Remove the discourse-rss-poster plugin and try again.


(Robby O'Connor) #3

He’s getting throttled by Rubygems. Where are you hosted?


(Алексей Копаев) #4

Thanks huge for the help, after removal of a plug-in discourse-rss-poster, discourse has successfully restarted. @LeoMcA what can be problematic with your plugin? You can view?


(Robby O'Connor) #5

If you read the errors, you’re being throttled by rubygems. So your issue wasn’t that plugin per se, but that you got throttled.


(Алексей Копаев) #6

Tell me, how can I fix this?


(cpradio) #7

Well, you can wait 24 hours and try re-enabling the plugin and doing another rebuild, maybe by then rubygems might not be throttling you (though to be honest, I’m not sure I see it as a throttling issue, considering the error happens between two rubygem downloads/installs… that or I’m reading the output wrong).


(Robby O'Connor) #8

The issue is that your ip block is likely hammering the rubygems server…the solution is likely to use something like DigitalOcean, I rarely have this issue. Something is weird but this is not a discourse issue, you should contact rubygems – you can read more about it here. I never actually saw this issue. I use Rackspace for the discourse instance I maintain…I’d bet money this is an AWS issue.


(Алексей Копаев) #9

Tried to plugin the plugin discourse-rss-poster , but the same error
https://pastebin.com/H8dSU9CF


(Robby O'Connor) #10

You are being throttled due to hitting the rate limit by rubygems. I repeat: this is not a discourse issue.

Look at line 639 onwards in your paste and read it ;).


(Robby O'Connor) #11

One other thing you could do: install another plugin in place of discourse-rss-poster – does that cause you to hit the rate limit as well? I suspect it will.


(Andrew Waugh) #12

Are you using a plain Ubuntu AMI, or did you take a prebuilt one from the marketplace?

Last week someone was having similar problems with an Intuz pre-built AMI - the issues went away when they moved to a plain Ubuntu 16 AMI and migrated their instance. See here:


(Алексей Копаев) #13

And why if I disabled the plug-in “discourse-rss-poster” then everything works.
But is it worth it to include, then download discourse fails?


(Алексей Копаев) #15

Updated the discourse to the latest version, when the plug-in is activated, the discourse never starts. Is this problem in the discourse-rss-poster plug-in?


(Robby O'Connor) #16

@11145 – where is this hosted?


(Алексей Копаев) #17

Answered in a personal