Rebuild not pulling from docker


My site has been offline for a few months, so I went to rebuild it and clean anything up.
When I went to do it, it seems to not be pulling correctly.

When trying to run the Hello World app, Docker says it’s fine.

root@PreloadService-Forum:/var/discourse# docker run -it --rm hello-world
Unable to find image 'hello-world:latest' locally
latest: Pulling from library/hello-world
2db29710123e: Pull complete 
Digest: sha256:6e8b6f026e0b9c419ea0fd02d3905dd0952ad1feea67543f525c73a0a790fefb
Status: Downloaded newer image for hello-world:latest

Hello from Docker!
This message shows that your installation appears to be working correctly.

To generate this message, Docker took the following steps:
 1. The Docker client contacted the Docker daemon.
 2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
 3. The Docker daemon created a new container from that image which runs the
    executable that produces the output you are currently reading.
 4. The Docker daemon streamed that output to the Docker client, which sent it
    to your terminal.

To try something more ambitious, you can run an Ubuntu container with:
 $ docker run -it ubuntu bash

Share images, automate workflows, and more with a free Docker ID:

For more examples and ideas, visit:


The vm hasn’t been touched in a few months and I’m confused as to why it’s not working. There’s another forum running on the same server (Not VM), and it works fine and was able to build correctly.

1 Like

Tried to rebuild via the legacy UI, and I got an error.


Stopping 7 Unicorn worker(s), to free up memory
Stopping job queue to reclaim memory, master pid is 3982
$ cd /var/www/discourse && git fetch --tags --force && git reset --hard HEAD@{upstream}
error: RPC failed; curl 56 GnuTLS recv error (-54): Error in the pull function.
error: 7257 bytes of body are still expected
fetch-pack: unexpected disconnect while reading sideband packet
fatal: early EOF
fatal: index-pack failed
#<RuntimeError: RuntimeError>
/var/www/discourse/plugins/docker_manager/lib/docker_manager/upgrader.rb:209:in `run'
/var/www/discourse/plugins/docker_manager/lib/docker_manager/upgrader.rb:87:in `block in upgrade'
/var/www/discourse/plugins/docker_manager/lib/docker_manager/upgrader.rb:70:in `each'
/var/www/discourse/plugins/docker_manager/lib/docker_manager/upgrader.rb:70:in `each_with_index'
/var/www/discourse/plugins/docker_manager/lib/docker_manager/upgrader.rb:70:in `upgrade'
/var/www/discourse/plugins/docker_manager/scripts/docker_manager_upgrade.rb:19:in `block in <main>'
/var/www/discourse/plugins/docker_manager/scripts/docker_manager_upgrade.rb:6:in `fork'
/var/www/discourse/plugins/docker_manager/scripts/docker_manager_upgrade.rb:6:in `<main>'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/railties- `load'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/railties- `perform'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/thor-1.2.1/lib/thor/command.rb:27:in `run'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/thor-1.2.1/lib/thor/invocation.rb:127:in `invoke_command'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/thor-1.2.1/lib/thor.rb:392:in `dispatch'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/railties- `perform'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/railties- `invoke'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/railties- `<main>'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/bootsnap-1.15.0/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:32:in `require'
/var/www/discourse/vendor/bundle/ruby/3.1.0/gems/bootsnap-1.15.0/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:32:in `require'
bin/rails:18:in `<main>'
Spinning up 7 Unicorn worker(s) that were stopped initially

1 Like

I had this exact bug a month ago, and I solved it by updating my wifi drivers in the laptop where this was happening.

Anyway, this bug means that your internet/network connection is not working properly, and can happen for many reasons.

1 Like

The site works, I can pull from docker correctly, and other sites on the same machine can work (The server is running proxmox), so I’m not sure what the issue could be.

My laptop was apparently fine too, I was playing online games, chatting on Discord, etc.

I was able to fix this myself.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.