Rendering bugs in new commit

Noticed two bugs when I upgraded to the latest:

  1. Editing a post and saving it keeps the transparency even after saving. You need to refresh to see the post normally. First posts in a topic aren’t affected but subsequent ones are.
  2. Instagram links no longer get a onebox - just show up as a link.


What browser is this happening on, is it also happening on meta?

(I am unable to reproduce on this post).


@sam its happening on Meta with both Firefox and Chrome. It only happens when you edit a post and save without making any actual edits (just click save without changing anything).

If you can’t reproduce, you could go to this post and try it:

The strange thing is that its only happening with some posts - for example, it doesn’t happen on this post - maybe because its still under the 5m edit time? EDIT: Yep, does this after the 5m editing time has elapsed. If you try it on your post now it should reproduce the bug.

1 Like

Hmm still not happening for me, but @nbianca has a related fix, merging it now, should be live in 20 minutes here. Let me know in an hour or so if this persists.


@sam I think that’s because you added a . in your edit. If I open a post to edit it and save without making any changes, it reproduces it for me.

1 Like

Still no repro, but probably cause I am running a slightly different code path since I am an administrator.


Still happening for me :frowning:


Aha, yes I have a repro here. @nbianca maybe it is related to your change.

  • Make a post
  • Wait 6 minutes
  • Click edit
  • Change nothing
  • Click save

Should be fixed per:

Will be merged in soon.


This topic was automatically closed after 15 hours. New replies are no longer allowed.