Request header field Dont-Chunk is not allowed by Access-Control-Allow-Headers in preflight response


(Brahn) #1

After setting up Full site CDN acceleration for Discourse I am seeing the following in chrome console:

XMLHttpRequest cannot load https://mydomain.com/message-bus/d487d3e56113405b95d297fbc468c99d/poll?dlp=t. Request header field Dont-Chunk is not allowed by Access-Control-Allow-Headers in preflight response.

Also, it doesn’t seem to always happen and it seems to be only those requests with the ?dip=t parameter:

The site is on stable, v1.6.1 and I am assuming that something in my config is not quite right but I am not sure where to start.

Any hints on where to look or how to approach diagnosing this?


(Sam Saffron) #2

Interesting, this is actually a but in our Access control process


(Sam Saffron) #3

Can you try:


(Brahn) #4

Thanks @sam
Can I push that into the rails app within the container somehow, just for testing, or is the only way to rebuild on the development branch?

Edit: I entered the app, edited this file and restart unicorn. That sound about right? Testing now…


(Brahn) #5

This appears to be working for me now. Many thanks!


(Sam Saffron) #6