Restore Failed Arguments should be provided as separate strings

I tried to move my discourse from digitalocean to ovh. I have follow all the official guideline.

The only one that different is, I used rsync method to move my backup because I always failed to upload my backup manually.

rsync -avz /var/discourse/shared/standalone/backups/default/* root@new-server:/var/discourse/shared/standalone/backups/default/

Here is my log in the end part:

[2021-04-16 00:36:49] ALTER TABLE
[2021-04-16 00:36:49] Migrating the database...
[2021-04-16 00:36:49] EXCEPTION: Arguments should be provided as separate strings
[2021-04-16 00:36:49] lib/discourse.rb:105:in `execute_command'
lib/discourse.rb:93:in `exec'
lib/discourse.rb:43:in `execute_command'
/var/www/discourse/lib/backup_restore/database_restorer.rb:133:in `migrate_database'
/var/www/discourse/lib/backup_restore/database_restorer.rb:27:in `restore'
/var/www/discourse/lib/backup_restore/restorer.rb:51:in `run'
/var/www/discourse/script/spawn_backup_restore.rb:23:in `restore'
/var/www/discourse/script/spawn_backup_restore.rb:36:in `block in <main>'
/var/www/discourse/script/spawn_backup_restore.rb:4:in `fork'
/var/www/discourse/script/spawn_backup_restore.rb:4:in `<main>'
[2021-04-16 00:36:49] Trying to rollback...
[2021-04-16 00:36:49] Rolling back...
[2021-04-16 00:36:49] Cleaning stuff up...
[2021-04-16 00:36:49] Dropping functions from the discourse_functions schema...
[2021-04-16 00:36:49] Removing tmp '/var/www/discourse/tmp/restores/default/2021-04-16-001234' directory...
[2021-04-16 00:36:49] Unpausing sidekiq...
[2021-04-16 00:36:49] Marking restore as finished...
[2021-04-16 00:36:50] Notifying 'admin' of the end of the restore...

I have upgrade my discourse to the latest.
I guess the error is " Arguments should be provided as separate strings".

thank you

1 Like

There is a bug report about a similar issue from a few hours ago: Importing a backup into a fresh 2.7.0.beta7 fails with "Arguments should be provided as separate strings". That issue has now been fixed. It would be worth trying to update your site to the latest Discourse code and running the restore again.

3 Likes

Did this resolve your issue?

1 Like

Thank you for your attention Mr. Jeff.

I do not know. Two days ago, I tried to move my discourse again but it is failed for several attempts. However, the problem is not related to this issue. Probably I need to order new fresh server again or trying another vps provider.

I need back to work again.

I will try to move my discourse again next week and definitely I will report it again here.

thank you…

1 Like

Resolve :white_check_mark:

Thank you Discourse for wonderful support and a mighty forum machine. :heart:

I Love You Reaction GIF

1 Like