Restoring Mis-Clicked ❤ Throws a User Error Message

I wanted to see the 'like history on a post and clicked on the heart rather than the number next to it. That cleared my :heart: and reduced the counter and now I get this message when I try to restore it:

HOWEVER, my user avatar was still there. By the time I managed to capture screenshots and compose this message, I was able to refresh the page and see the heart filled in and the correct count.

This does complicate the poor aim with a mouse click situation, but also raises the question of how to clear/withdraw a :heart: reliably. I’m done fiddling with this for today and will let someone test that.

Are you able to reproduce this on this post?

1 Like

I’m not. And not on my setup either. So, I would guess it is not a bug.

1 Like

Sorry, guys. I left out a step and also misreported the procedure. The trigger for the bug was when I tried to close the :heart: queue (or whatever you guys call it) and clicked the :heart: instead of the queue count.

I don’t recall the exact steps from yesterday but was able to reproduce it here just now.

  1. Set the :heart:
  2. expand the :heart: queue
  3. clear the :heart:
  4. restore the :heart:

You should get the error message when trying to restore the heart. See if you can reproduce the behavior with the steps above before delving in to the following detail. It gets pretty weird.

For the record, I’m a developer of industrial automation, robotics, and vision systems so my bug reports are usually very reliable.

P.S. I can barely see the dividing line below. Does it render with decent contrast for anyone? (Please report your active theme.)


I made this happen one time on @sam’s post and then refreshed the page to see if that would clear the hung state of the :heart:. When I refreshed the page to test more, the :heart: behaved as expected. @Jagster’s post also worked as it should right after the refresh (I hadn’t done anything with it prior to the refresh). I could set and clear the heart.

image

HOWEVER, after a short time, I was not able to clear the :heart: on Sam’s post and then Jakke’s psot was hanging in the set() state as reported in the OP, throwing the error:

image

See if you can reproduce it with the steps above. I think it has to do with setting and then clearing :heart: with the queue open in the same page visit.

If I can report any more detail on how to reproduce this, I will. Jakke’s post changing behavior without a refresh was very odd.

1 Like

I tried to reproduce this issue here on meta and I am able to reproduce it. I think it’s rate limiting issue. When I click the like 3-4 time in less that 30 seconds I get rate limiting error saying I have to wait for 30 seconds to perform this action again. I repeated this 2 times. After that I got this same error.

I think that’s due to discourse thinks you are a bot and trying to do something wrong.

1 Like

So perhaps we can classify this as “quirky behavior unless you refresh the page”.

Makes sense, though the error message doesn’t communicate this because it appears to be a system message (from the program execution environment/shell, not the Discourse application itself) rather than than a user error message.

…and 24 hours later, I still can’t clear either "heart: from Sam’s or Jakke’s posts. This might be the edit_window_time expiring. (setting name is pseudocode.)

image

This is due to setting post undo action window time

You can not revoke the like after the time set in this setting

2 Likes

Thanks for checking, Ahmed. I figured it was a timeout window, just didn’t expect to hit one so soon.

10 minutes is pretty short. I might want to revoke the :heart: based on something from that poster later in the conversation.

1 Like