Run-together markdown formatting mixed with html makes images not load

I see, thanks for clarifying. Honestly, this is unlikely to change anytime soon for the reasons discussed in the topic I linked above. For example

The key thing for us is to maintain the integrity of the content, so the newline solution will probably not happen.

The problem is that if you were to try and autocorrect for the issue you’re describing it would potentially create other issues. The current solution here is to add your wordpress domain to the disabled image download domains site setting.

edit I’ve made a small proposal on that front, but it’s speculative and I would reiterate that the current solution here is to disable image downloads for your WP domain.