Schedule Topic - Possible Bug


(Rob Meade) #1

Hi,

I’ve not used this functionality before but did today for the first time, looks really useful, I think I may have spotted an issue though, see below.


Steps I took;

  • I created my topic, setting it to Unlisted so that it wouldn’t be displayed before I could set the scheduling options

  • I then used the Topic Admin Actions to schedule its publication (shame I couldn’t do that before submitting it actually).

  • Once created, I then set the topic back to Listed.


What I experienced;

  • At the bottom of the topic I can see this;

  • Selecting Set Topic Timer… again, from the Admin Topic Actions, displays this;


Assumptions;

It looks like because the Category I have already selected is removed from the Publish To list (which in one sense makes sense), this modal isn’t able to pre-select the option.

I am also assuming that the message at the bottom, where the name of the selected Category is missing, is also taken from the selected value of this drop down menu.

If I expand and scroll, or search the Publish To menu, my original selection is not available/displayed.


I hope this is of some use - if I have used it incorrectly, please do let me know :slight_smile:


(Rob Meade) #2

As an update to this I have signed out and can actually see the topic posted already, which leaves me to think that the sequence I used to do this was incorrect.

Can anyone advise, if I set a topic as unlisted, does setting the publishing timer then make it listed? Trying to establish what I need to do to create a topic without it being visible until that publication date/time etc. Thanks:)


(Daniela) #3

Your sequence of steps has been

  • create a topic and after
  • make the topic unlisted

Is it correct?


(Sam Saffron) #4

Setting the timer should not make any changes, but as soon as it is published it should become listed.


(Rob Meade) #5

Hi @Trash,

Originally, it was;

  • +New Discussion
  • Select category
  • Add title text
  • Add body text
  • Toggle Unlisted (making it unlisted)

I assumed I needed to do this to be able to actually create the post before selecting the options to schedule the publication.

Having scheduled it, I then set it back as listed.

I’ve just had a play/test and realise now what the Schedule Publication actually does, from what I can see it simply toggles unlisted to listed and displays the post creation time of that of the scheduled publication, rather than when the topic was composed.

Based on this, I’ve gone back in and set the topic I wanted to schedule to unlisted so that it will appear in a couple of days.

However, the above error was still displayed and I don’t think it is related to the steps I took.


(Rob Meade) #6

Hi @sam,

Thanks for the reply.

As the modal has a “Publish To” field, does that mean that you could potentially create the topic in one category, and then select another on that modal window and have it post the topic to another category on the selected date/time?


(Sam Saffron) #7

No, we do not create copies of the topic, we just amend the category on the existing topic and make sure it is visible.


(Rob Meade) #8

Sorry, that was what I meant, so in effect the topic is “moved”?


(Sam Saffron) #9

yes, topic category id changes from 1 to 2 …


(Rob Meade) #10

Cool thanks, makes sense to me now :slight_smile:


(Sam Saffron) #11

So, is there anything buggy left here?


(Rob Meade) #12

just my original post really Sam… despite my lack of understanding, the error at the bottom of that screenshot appeared when I went “back in” to the existing scheduled publication settings.


(Sam Saffron) #13

@tgxworld can you have a look at this?


(Rob Meade) #18

Hi all,

Any news/updates on this one?

Thanks in advance :slight_smile:


(Sam Saffron) #19

It is a assigned to @tgxworld he does have a fairly full plate at the moment, but it is absolutely in the pipeline :man_factory_worker:t4:


(Rob Meade) #20

Hi @sam,

Awesome, thanks for the update - appreciated :slight_smile:


(Alan Tan) #21

Thank you @RobMeade, this was indeed a bug :slight_smile: I’ve fixed it in

Thank you for reporting!


(Rob Meade) #22

Fantastic, thank you :slight_smile: :slight_smile:


(Alan Tan) #23

This topic was automatically closed after 2 days. New replies are no longer allowed.